Hdu4352 XHXJ's LIS

XHXJ's LIS

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3649    Accepted Submission(s): 1521

Problem Description
#define xhxj (Xin Hang senior sister(学姐)) 
If you do not know xhxj, then carefully reading the entire description is very important.
As the strongest fighting force in UESTC, xhxj grew up in Jintang, a border town of Chengdu.
Like many god cattles, xhxj has a legendary life: 
2010.04, had not yet begun to learn the algorithm, xhxj won the second prize in the university contest. And in this fall, xhxj got one gold medal and one silver medal of regional contest. In the next year's summer, xhxj was invited to Beijing to attend the astar onsite. A few months later, xhxj got two gold medals and was also qualified for world's final. However, xhxj was defeated by zhymaoiing in the competition that determined who would go to the world's final(there is only one team for every university to send to the world's final) .Now, xhxj is much more stronger than ever,and she will go to the dreaming country to compete in TCO final.
As you see, xhxj always keeps a short hair(reasons unknown), so she looks like a boy( I will not tell you she is actually a lovely girl), wearing yellow T-shirt. When she is not talking, her round face feels very lovely, attracting others to touch her face gently。Unlike God Luo's, another UESTC god cattle who has cool and noble charm, xhxj is quite approachable, lively, clever. On the other hand,xhxj is very sensitive to the beautiful properties, "this problem has a very good properties",she always said that after ACing a very hard problem. She often helps in finding solutions, even though she is not good at the problems of that type.
Xhxj loves many games such as,Dota, ocg, mahjong, Starcraft 2, Diablo 3.etc,if you can beat her in any game above, you will get her admire and become a god cattle. She is very concerned with her younger schoolfellows, if she saw someone on a DOTA platform, she would say: "Why do not you go to improve your programming skill". When she receives sincere compliments from others, she would say modestly: "Please don’t flatter at me.(Please don't black)."As she will graduate after no more than one year, xhxj also wants to fall in love. However, the man in her dreams has not yet appeared, so she now prefers girls.
Another hobby of xhxj is yy(speculation) some magical problems to discover the special properties. For example, when she see a number, she would think whether the digits of a number are strictly increasing. If you consider the number as a string and can get a longest strictly increasing subsequence the length of which is equal to k, the power of this number is k.. It is very simple to determine a single number’s power, but is it also easy to solve this problem with the numbers within an interval? xhxj has a little tired,she want a god cattle to help her solve this problem,the problem is: Determine how many numbers have the power value k in [L,R] in O(1)time.
For the first one to solve this problem,xhxj will upgrade 20 favorability rate。
Input
First a integer T(T<=10000),then T lines follow, every line has three positive integer L,R,K.(
0<L<=R<263-1 and 1<=K<=10).
Output
For each query, print "Case #t: ans" in a line, in which t is the number of the test case starting from 1 and ans is the answer.
Sample Input
1 123 321 2
Sample Output
Case #1: 139
Author
peterae86@UESTC03
Source
题目大意:一个数k的LIS称作这个数每个数位上的数字的LIS,例如1324的LIS为3. 求[L,R]中有多少个数的LIS = k.
分析:很显然,这是道数位dp题,但是要怎么记录状态呢?
   考虑LIS问题的O(nlogn)做法,每次插入一个数,找第一个大于这个数的数,弹出去,再插入这个数.最后还有多少个数,LIS就是多少。组成LIS的数字只有0~9,所以可以用一个二进制数S来表示状态,如果S的第i位为1,就说明i这个数存在.那么f[i][j]表示处理到第i位,状态为j的个数,这样处理就可以了.
   T比较大,每次初始化f数组的话会超时,能不能不清空呢?考虑到LIS的长度最大就是10,在状态后面再加一维f[i][j][k]表示处理到第i位,状态为j,并且LIS长度为k的个数,这样就不需要每次都初始化f了.
   细节:要排除前导0.
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

typedef long long ll;
int T,cas;
ll L,R,K,f[20][(1 << 10) + 1][11],num[20];

ll calc(ll S,ll &k,ll x)
{
    int cur = -1;
    for (ll i = x; i <= 9; i++)
        if (S & (1 << i))
        {
            cur = i;
            break;
        }
    if (cur == -1)
    {
        k++;
        S |= (1 << x);
    }
    else
    {
        S ^= (1 << cur);
        S |= (1 << x);
    }
    return S;
}

ll dfs(ll len,ll S,ll k,bool limit,bool flag)
{
    if (!len)
        return k == K;
    if (!limit && f[len][S][K] != -1)
        return f[len][S][K];
    ll maxx = (limit ? num[len] : 9),cnt = 0;
    for (ll i = 0; i <= maxx; i++)
    {
        ll tempk = k,tempS;
        if (!i && flag)
            tempS = 0;
        else
            tempS = calc(S,tempk,i);
        cnt += dfs(len - 1,tempS,tempk,i == maxx && limit,flag && !i);
    }
    if (!limit)
        return f[len][S][K] = cnt;
    return cnt;
}

ll solve(ll x)
{
    ll len = 0;
    while (x)
    {
        num[++len] = x % 10;
        x /= 10;
    }
    return dfs(len,0,0,1,1);
}

int main()
{
    memset(f,-1,sizeof(f));
    scanf("%d",&T);
    while (T--)
    {
        scanf("%lld%lld%lld",&L,&R,&K);
        printf("Case #%d: %lld\n",++cas,solve(R) - solve(L - 1));
    }

    return 0;
}

 

posted @ 2018-03-03 10:33  zbtrs  阅读(322)  评论(0编辑  收藏  举报