PAT Advanced 1008 Elevator(20)

题目描述:

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

算法描述:模拟

题目大意:

某栋楼只有一部电梯,先依次给出n个数,表示依次到达的楼层
上升需要6秒,下降需要4秒,停留一个楼层需要5秒
求遍历这n个楼层需要多少秒

#include<iostream>
using namespace std;

int main()
{
    int ans = 0, n, lev = 0;
    cin >> n;
    
    while(n --)
    {
        int x;
        cin >> x;
        
        if(x > lev)//上升 上升时间 + 停留时间
        {
            ans += (x - lev) * 6 + 5;
            lev = x;
        }
        else if(x < lev) // 下降
        {
            ans +=(lev - x) * 4 + 5;
            lev = x;
        }
        else // 原楼层  只需要加 停留的5秒
        {
            ans += 5;
        }
    }
    
    cout << ans << endl;
    return 0;
}
posted @ 2022-08-12 16:18  D_coding_blog  阅读(16)  评论(0编辑  收藏  举报