PAT Advanced 1006 Sign In and Sign Out(25)

题目描述:

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

算法描述:模拟 排序

题目大意:

给出m个同学的 到班时间 和 离开时间
输出第一个到教室的同学id 和 最后一个离开教师的同学id

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    int m;
    cin >> m ;
    string open_id,open_time;
    string close_id,close_time;
    
    for(int i = 0 ; i < m ; i++)
    {
        string id,in_time,out_time;
        cin >> id >> in_time >> out_time ;
        
        if(!i || in_time < open_time ){
            open_id = id ;
            open_time = in_time ;
        }
        if(!i || out_time > close_time){
            close_id = id ;
            close_time = out_time ;
        }
    }
    cout << open_id << " " << close_id ;
    return 0;
}
posted @ 2022-08-12 16:11  D_coding_blog  阅读(16)  评论(0编辑  收藏  举报