acm hdoj 1157

Who's in the Middle

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3136 Accepted Submission(s): 1171
 
Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 
Input
* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 
Output
* Line 1: A single integer that is the median milk output.
 
Sample Input
5
2
4
1
3
5
 
Sample Output
3
Hint
INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.
 

 

第一次:结果错误

 

#include<stdio.h>
#include<stdlib.h>
#include <iostream>
using namespace std;

int comp(const void *a,const void *b)
{
    return *(int*)a-*(int*)b;
}

int cow[10005];


int main()
{
    //freopen("1.txt","r",stdin);
    
    int N;
    scanf("%d",&N);
    int i=0;
    for(i=0;i<N;i++)
    {
        scanf("%d",&cow[i]);
    }
    qsort(cow,N,sizeof(int),comp);
    printf("%d\n",cow[N/2]);
    
    
    
    return 0;
}

 

让后我从网上找了别人的代码看,看看没什么不同

 

第二次,每次都处理,但是超时

 

#include<stdio.h>
#include<stdlib.h>
#include <iostream>
using namespace std;

int comp(const void *a,const void *b)
{
    return *(int*)a-*(int*)b;
}

int cow[10005];


int main()
{
    //freopen("1.txt","r",stdin);
    
    int N;
    while(scanf("%d",&N))
    {
        
        int i=0;
        for(i=0;i<N;i++)
        {
            scanf("%d",&cow[i]);
        }
        qsort(cow,N,sizeof(int),comp);
        printf("%d\n",cow[N/2]);
    }
    
    
    return 0;
}

 

 

第三次,加上了eof

 

#include<stdio.h>
#include<stdlib.h>
#include <iostream>
using namespace std;

int comp(const void *a,const void *b)
{
    return *(int*)a-*(int*)b;
}

int cow[10005];


int main()
{
    //freopen("1.txt","r",stdin);
    
    int N;
    while(scanf("%d",&N)!=EOF)
    {
        
        int i=0;
        for(i=0;i<N;i++)
        {
            scanf("%d",&cow[i]);
        }
        qsort(cow,N,sizeof(int),comp);
        printf("%d\n",cow[N/2]);
    }
    
    
    return 0;
}

 

posted @ 2015-05-11 11:58  yufenghou  阅读(181)  评论(0编辑  收藏  举报