The 17th Zhejiang University Programming Contest Sponsored by TuSimple J

Knuth-Morris-Pratt Algorithm

Time Limit: 1 Second      Memory Limit: 65536 KB

In computer science, the Knuth-Morris-Pratt string searching algorithm (or KMP algorithm) searches for occurrences of a "word" W within a main "text string" S by employing the observation that when a mismatch occurs, the word itself embodies sufficient information to determine where the next match could begin, thus bypassing re-examination of previously matched characters.

Edward is a fan of mathematics. He just learnt the Knuth-Morris-Pratt algorithm and decides to give the following problem a try:

Find the total number of occurrence of the strings "cat" and "dog" in a given string s.

As Edward is not familiar with the KMP algorithm, he turns to you for help. Can you help Edward to solve this problem?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 30), indicating the number of test cases. For each test case:

The first line contains a string s (1 ≤ |s| ≤ 1000).

Output

For each case, you should output one integer, indicating the total number of occurrence of "cat" and "dog" in the string.

Sample Input

7
catcatcatdogggy
docadosfascat
dogdddcat
catcatcatcatccat
dogdogdogddddooog
dcoagtcat
doogdog

Sample Output

4
1
2
5
3
1
1

Hint

For the first test case, there are 3 "cat" and 1 "dog" in the string, so the answer is 4.

For the second test case, there is only 1 "cat" and no "dog" in the string, so the answer is 1.

题意:很明显的

解法:KMP

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;
char t[10050],s[1000007];
int flink[10004];
void cmd(char *t)
{
    int i=0,j=-1;
    flink[0]=-1;
    int len=strlen(t);
    while(i<len)
    {
        if(j==-1 || t[i]==t[j])
            flink[++i]=++j;
        else
            j=flink[j];
    }
}
int sum(char *t,char *s)
{
    int ans=0;
    int i=0,j=0;
    int n=strlen(t);
    int len;
    len=strlen(s);
    while(i<len)
    {
        if(j==-1 || s[i]==t[j])
        {
            ++i;
            ++j;
        }
        else
        {
            j=flink[j];
        }
        if(j==n) ans++;
    }
    return ans;
}
int main()
{
    int c;
    scanf("%d",&c);
    while(c--)
    {
        scanf("%s",s);
        cmd("cat");
        int a=sum("cat",s);
        cmd("dog");
        int b=sum("dog",s);
        printf("%d\n",a+b);
    }
    return 0;
}

 

posted @ 2017-04-13 00:20  樱花落舞  阅读(426)  评论(0编辑  收藏  举报