poj 3169 Layout(线性差分约束,spfa:跑最短路+判断负环)

Layout
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15349   Accepted: 7379

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

Source

 
题目意思:
给n,m1,m2
n头牛,每头牛跟其他的牛直接的距离有一定的约束
m1个约束1,m2个约束2
约束1:
a b c 表示a牛和b牛之间的距离最多c
约束2:
a b c 表示a牛和b牛之间的距离最少c
问你两头牛之间的最大距离至少是多少才能满足所有的约束
分析:
x[i]表示牛i的在x[i]处或者说牛i在距离原点x[i]的地方
约束1可以表示为:
x[a]-x[b]<=c
约束2可以表示为:
x[b]-x[a]<=-c
<=代表的是最大值,代表的是最短路,表达式形式为x[i]-x[j]<=c
按照j到i建图,权值为c
然后起点是1,跑个最短路(不能使用dj,因为存在负权)
1到n的最短路就是能满足所有牛约束的最小距离值
code:
#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string.h>
#include<set>
#include<map>
#include<list>
#include<math.h>
#include<queue>
#include<algorithm>
using namespace std;
typedef long long LL;
#define INF 9999999999
#define me(a,x) memset(a,x,sizeof(a))
int mon1[13]= {0,31,28,31,30,31,30,31,31,30,31,30,31};
int mon2[13]= {0,31,29,31,30,31,30,31,31,30,31,30,31};
int dir[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};

int getval()
{
    int ret(0);
    char c;
    while((c=getchar())==' '||c=='\n'||c=='\r');
    ret=c-'0';
    while((c=getchar())!=' '&&c!='\n'&&c!='\r')
        ret=ret*10+c-'0';
    return ret;
}
void out(int a)
{
    if(a>9)
        out(a/10);
    putchar(a%10+'0');
}

#define max_v 1005
struct node
{
    int v;
    LL w;
    node(int vv=0,LL ww=0):v(vv),w(ww){}
};
LL dis[max_v];
int vis[max_v];
int cnt[max_v];
vector<node> G[max_v];
queue<int> q;

void init()
{
    for(int i=0;i<max_v;i++)
    {
        G[i].clear();
        dis[i]=INF;
        vis[i]=0;
        cnt[i]=0;
    }
    while(!q.empty())
        q.pop();
}

int spfa(int s,int n)
{
    vis[s]=1;
    dis[s]=0;
    q.push(s);
    cnt[s]++;

    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        vis[u]=0;

        for(int j=0;j<G[u].size();j++)
        {
            int v=G[u][j].v;
            LL w=G[u][j].w;

            if(dis[v]>dis[u]+w)
            {
                dis[v]=dis[u]+w;
                if(vis[v]==0)
                {
                    q.push(v);
                    cnt[v]++;
                    vis[v]=1;

                    if(cnt[v]>n)
                        return 0;
                }
            }
        }
    }
    return 1;
}
int f(int u,int v)
{
    for(int j=0;j<G[u].size();j++)
    {
        if(G[u][j].v==v)
            return 0;
    }
    return 1;
}
int main()
{
    int n,a,b;
    while(~scanf("%d %d %d",&n,&a,&b))
    {
        init();
        int x,y,w;
        while(a--)
        {
            scanf("%d %d %d",&x,&y,&w);
            if(f(x,y))
                G[x].push_back(node(y,w));
        }
        while(b--)
        {
            scanf("%d %d %d",&x,&y,&w);
            if(f(y,x))
                G[y].push_back(node(x,-w));
        }
        int flag=spfa(1,n);
        if(flag==0)
        {
            printf("-1\n");
        }else if(dis[n]<INF)
        {
            printf("%lld\n",dis[n]);
        }else
        {
            printf("-2\n");
        }
    }
    return 0;
}
/*
题目意思:
给n,m1,m2
n头牛,每头牛跟其他的牛直接的距离有一定的约束
m1个约束1,m2个约束2
约束1:
a b c 表示a牛和b牛之间的距离最多c
约束2:
a b c 表示a牛和b牛之间的距离最少c
问你两头牛之间的最大距离至少是多少才能满足所有的约束

分析:
x[i]表示牛i的在x[i]处或者说牛i在距离原点x[i]的地方

约束1可以表示为:
x[a]-x[b]<=c
约束2可以表示为:
x[b]-x[a]<=-c

<=代表的是最大值,代表的是最短路,表达式形式为x[i]-x[j]<=c
按照j到i建图,权值为c
然后起点是1,跑个最短路(不能使用dj,因为存在负权)
1到n的最短路就是能满足所有牛约束的最小距离值

*/

 

posted @ 2018-11-22 16:16  西*风  阅读(236)  评论(0编辑  收藏  举报