学为所用

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Windows7安装PowerShell5.1方法(Flutter新版本需要)

  重新安装Windows7系统,在使用Flutter的时候,发现需要PowerShell5.0以上版本,需要升级Windows7里自带的PowerShell2.0到5.0以上,到微软官网上查可以升级到5.1,下面记录一下升级过程。

查看PowerShell当前版本

  在开始菜单--所有程序--附件中找到PowerShell打开,在PowerShell命令行中输入:

$PSVersionTable.PSVersion

或者

Get-Host | Select-Object Version

  然后回车,就可以看到当前PowerShell的版本是多少了。Windows7默认看到的应该是2.0。
  注意,这里所说的Windows7是指Windows7 SP1,如果没有打SP1补丁的,请打SP1补丁或直接安装Windows7 SP1系统,否则使用不了PowerShell5.1的升级包。

下载PowerShell5.1升级包

  在浏览器中访问 https://www.microsoft.com/en-us/download/details.aspx?id=54616,打开后,如下图:

  点击页面中的红色按钮Download,进入选择页面,如下图:

  选择Win7AndW2K8R2-KB3191566-x64.zip,然后点右下角的Next按钮,页面跳转后稍等一会,就会弹出下载文件对话框,选择本地保存位置后开始下载。

安装PowerShell5.1升级包

检查运行环境

  安装PowerShell5.1,至少需要.NET Framework 4.5.2,如果系统当前.NET Framework版本低于这个版本,需要先升级.NET Framework,具体操作查看另一篇博文。

修改PowerShell执行脚本权限

  安装PowerShell5.1,需要在之前的PowerShell上运行脚本,Windows7默认的PowerShell2.0是不允许运行脚本的,要先更改一下权限,具体步骤如下:

  1、在开始菜单--所有程序--附件--Windows PowerShell--Windows PowerShell上鼠标右键,以管理员身份运行,打开PowerShell2.0。

  2、在PowerShell命令行中输入

Set-ExecutionPolicy RemoteSigned -Force

然后回车,没有出现任何错误信息,表示权限策略修改完成。

  3、验证权限策略是否修改正确,在PowerShell命令行中输入

Get-ExecutionPolicy

  然后回车,如果看到命令行输出

RemoteSigned

  则表示修改成功。

执行脚本安装

  1、将下载的Win7AndW2K8R2-KB3191566-x64.zip压缩包解压到一个新的文件夹内,例如解压后的完整路径是“D:\Shell”。解压后的文件夹里应该可以看到下图的两个文件:

  2、在PowerShell命令行中输入

cd D:\Shell

  回车后进入刚才解压出来的文件夹内

  3、然后执行里面的Install-WMF5.1.ps1脚本,在PowerShell命令行中输入

Install-WMF5.1.ps1

  回车后开始执行Install-WMF5.1.ps1脚本,这个过程可能会比较长,因为要在微软官网在线下载更新,所以网络不是很通常,请耐心等待安装完成。

  安装完成后,重新启动PowerShell,使用上述查看版本的命令再次查看,应该显示的就是5.1版本了。

作者:学为所用
本文为博主原创,未经允许不得转载。若博主同意转载的但必须给出原文链接,并保留此段声明,否则保留追究法律责任的权利。
posted on 2019-11-23 10:20  学为所用  阅读(5293)  评论(3编辑  收藏  举报