HDU-2052Picture

Problem Description
Give you the width and height of the rectangle,darw it.
 
Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
 
Output
For each case,you should draw a rectangle with the width and height giving in the input. after each case, you should a blank line.
 
Sample Input
3 2
 
Sample Output
+---+ | | | | +---+
 
#include<stdio.h>
int main() {
    int
n,m;
    while
(scanf("%d%d",&n,&m)!=EOF){
        printf("+");
        for
(int i=1;i<=n;++i)
        printf("-");
        printf("+\n");
        for
(int i=1;i<=m;++i) {
            for
(int j=1;j<=n+2;++j)
            if
(j==1||j==(n+2)) printf("|");
            else

            printf(" ");
            printf("\n");
        }

        printf("+");
        for
(int i=1;i<=n;++i)
        printf("-");
        printf("+\n\n");
    }

    return
0;
}
posted @ 2013-04-14 14:30  xiaxiaosheng  阅读(160)  评论(0编辑  收藏  举报