HDU-2071Max Num

Problem Description
There are some students in a class, Can you help teacher find the highest student .
 
Input
There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.
 
Output
For each case output the highest height, the height to two decimal plases;
 
Sample Input
2 3 170.00 165.00 180.00 4 165.00 182.00 172.00 160.00
 
Sample Output
180.00 182.00
 
#include<stdio.h>
int T,n;
int main() {
 scanf("%d",&T);
 while(T--) {
  scanf("%d",&n);
  double max=-9999,h;
  for(int i=1;i<=n;++i) {
   scanf("%lf",&h);
   if(h>max)
   max=h;
  }
  printf("%.2lf\n",max);
 }
 return 0;
}
  
posted @ 2013-04-14 14:28  xiaxiaosheng  阅读(137)  评论(0编辑  收藏  举报