pcre-8.20编译安装出错[pcrecpp.lo] Error 1

这几天想在测试机上将Apache与Tomcat整合,哪知CentOS5.5 内置的httpd貌似有点问题,不想去研究具体问题出在哪儿,索性安装个新版的好了。然后在编译过程中,发现少了一堆包,像apr- 1.4.6.tar.gz、apr-util-1.4.1.tar.gz、pcre-8.20.tar.gz···前2个编译安装倒没啥大问题,无非是编 译的时候写好路径参数,但最后一个玩意儿,就有点麻烦···嗯,还是百度了一下,把以下转载内容贴上以供分享···

 

下载pcre-8.20编译安装,make时报错:

source='pcrecpp.cc' object='pcrecpp.lo' libtool=yes
        DEPDIR=.deps depmode=none /bin/sh ./depcomp
        /bin/sh ./libtool --tag=CXX   --mode=compile  -DHAVE_CONFIG_H -I.   -I/usr/kerberos/include   -c -o pcrecpp.lo pcrecpp.cc
libtool: ignoring unknown tag CXX
libtool: unrecognized option `-DHAVE_CONFIG_H'
Try `libtool --help' for more information.
make[1]: *** [pcrecpp.lo] Error 1

这个错误,基本可以断定是缺少系统包造成的,但是缺少哪个包却不明确,这里记录下,这个错误是缺少安装gcc-c++,只需yum -y install gcc-c++,重新configure,make && make install通过。

编译安装完成,再安装Apache。。。

OK,新Apache安装成功鸟!

posted @ 2012-04-16 15:21  wenanry  阅读(12996)  评论(2编辑  收藏  举报