Problem Description
对于给定的一个字符串,统计其中数字字符出现的次数。

Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。

Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。

Sample Input
2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf

Sample Output
6
9

需要注意的只有一个地方,就是输入数字后回车的处理。

import java.util.Scanner;
class Main{
    public static void main(String args[]){
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        String str1 = sc.nextLine();
        while(t-->0){
            String str = sc.nextLine();
            int lengnum = 0;
            for(int i=0;i<str.length();i++){
                char cstr = str.charAt(i);
                if(cstr>='0'&&cstr<='9'){
                    lengnum++;                  
                }               
            }
            System.out.println(lengnum);            
        }       
    }
}
posted on 2015-11-16 16:51  cnxo  阅读(153)  评论(0编辑  收藏  举报