1045 Favorite Color Stripe (30)

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (<=200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (<=10000) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7
//最长不下降子序列 
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 210;
const int maxc = 10010;
int hashTable[maxn];    
int A[maxc],dp[maxc];   //数组A和dp的大小和L有关 
int main(){
    int n,m,x;
    memset(hashTable,-1,sizeof(hashTable));
    scanf("%d%d",&n,&m);
    for(int i = 0; i < m; i++){
        scanf("%d",&x);
        hashTable[x] = i;
    }
    int L,num = 0;
    scanf("%d",&L);
    for(int i = 0; i < L; i++){
        scanf("%d",&x);
        if(hashTable[x] >= 0){
            A[num++] = hashTable[x];
        }
    }
    int ans = -1;
    for(int i = 0; i < num; i++){
        dp[i] = 1;
        for(int j = 0; j < i; j++){
            if(A[i] >= A[j] && dp[i] < dp[j] + 1){
                dp[i] = dp[j] + 1; 
            }
        }
        ans = max(ans,dp[i]);
    }
    printf("%d",ans);
    return 0;
}

 

//最长公共子序列 
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 210;
const int maxL = 10010;
int dp[maxL][maxL],A[maxn],B[maxL];
int main(){
    int n,m,x;
    scanf("%d%d",&n,&m);
    for(int i = 1; i <= m; i++){   //[1,n] 
        scanf("%d",&A[i]);
    }
    int L;
    scanf("%d",&L);
    for(int i = 1; i <= L; i++){  //[1,L]
        scanf("%d",&B[i]);
    }
    for(int i = 0; i <= m; i++){  //[0,m]
        dp[i][0] = 0;
    }
    for(int i = 0; i <= L; i++){  //[0,L]  四个取值范围存疑 
        dp[0][i] = 0;
    }
    for(int i = 1; i <= m; i++){
        for(int j = 1; j <= L; j++){
            int MAXV = max(dp[i-1][j],dp[i][j-1]);
            if(A[i] == B[j]){
                dp[i][j] = MAXV+1;
            }else{
                dp[i][j] = MAXV;
            }
        }
    }
    printf("%d",dp[m][L]);
    return 0;
}

 

posted @ 2018-07-25 11:03  王清河  阅读(93)  评论(0编辑  收藏  举报