10-排序5 PAT Judge (25 分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N(10​^4​​), the total number of users, K (≤5), the total number of problems, and M (≤10^5), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either − if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -
//用户id 00001 - N
//问题id 1 - K
//p[i] 第i个问题的满分

//M行 用户id 问题id 得分(-1提交未能通过编译,[0-p[i]分]) 

/*
输入格式
rank user_id total_score s[1]...s[k] 
rank 名次,总分相同,名词相同 按满分数量和 按id非递减方式排序 
s[1]...s[k] 提交问题获得的分数,如果没有提交输出- ,提交数次取最高分
没有提交任何解决方案或者任何解决方案都没有通过编译的就不进行排序了 
*/ 

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 100010;

struct Student
{
    int id;
    int score[6]; //总分以及1-k(<=5)问题得分 总分初始化为0,各题目初始化-1 
    int num_full;    //满分题目数,初始化0
    bool isSummit;
}stu[maxn];

void init(int n,int k);
bool cmp(Student a, Student b);

int main()
{
    int n,k,m;
    int full_mark[6];
    scanf("%d%d%d", &n, &k, &m);

    init(n,k);
    
    for (int i = 1; i <= k; i++)
    {
        scanf("%d",&full_mark[i]);
    }
    
    int id, num_ques, nGrade;
    for (int i = 0; i < m; i++)
    {
        scanf("%d %d %d",&id, &num_ques, &nGrade);
        
        stu[id].id = id;
        if (nGrade == -1 && stu[id].score[num_ques] == -1)
        {
            stu[id].score[num_ques] = 0;
        }
        if (nGrade != -1)
        {
            stu[id].isSummit = true;
        }
        if (stu[id].score[num_ques] < nGrade) //分数大于已保存的,更替 
        {

            stu[id].score[num_ques] = nGrade;
            if (nGrade == full_mark[num_ques])    //满分时,满分数量+1 
            {
                stu[id].num_full++;
            }
        }
    }
    
    for (int i = 1; i <= n; i++)
    {
        for (int j = 1; j <= k; j++)
        {
            if (stu[i].score[j] != -1)
            {
                stu[i].score[0] += stu[i].score[j];    
            }    
        } 
    }
    
    sort(stu+1, stu+n+1, cmp);
    
    int rank = 1;
    for (int i = 1; i <= n; i++)
    {
        if (!stu[i].isSummit)
        {
            break;
        }
        if (i != 1 && stu[i].score[0] != stu[i-1].score[0])
        {
            rank = i;    
        }    
        printf("%d %05d %d ", rank, stu[i].id, stu[i].score[0]);
        for (int j = 1; j <= k; j++)
        {
            if (stu[i].score[j] == -1)
            {
                printf("-");
            }
            else
            {
                printf("%d",stu[i].score[j]);
            }
            
            if (j < k)
            {
                printf(" ");
            }
            else
            {
                printf("\n");
            }
        }
    } 
    
    return 0;
}

void init(int n,int k)
{
    for (int i = 1; i <= n; i++)
    {
        stu[i].score[0] = 0;
        stu[i].num_full = 0;
        stu[i].isSummit = false;
        for (int j = 1; j <= k; j++)
        {
            stu[i].score[j] = -1;
        }
    }
}

bool cmp(Student a, Student b)
{
    if (a.isSummit != b.isSummit)
    {
        return a.isSummit > b.isSummit;
    }
    else if (a.score[0] != b.score[0])
    {
        return a.score[0] > b.score[0];
    }
    else if (a.num_full != b.num_full)
    {
        return a.num_full > b.num_full;
    }
    else
    {
        return a.id < b.id;
    }
}

 

posted @ 2019-11-23 10:46  王清河  阅读(207)  评论(0编辑  收藏  举报