hdu 1597 find the nth digit

find the nth digit

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9836    Accepted Submission(s): 2881


Problem Description
假设:
S1 = 1
S2 = 12
S3 = 123
S4 = 1234
.........
S9 = 123456789
S10 = 1234567891
S11 = 12345678912
............
S18 = 123456789123456789
..................
现在我们把所有的串连接起来
S = 1121231234.......123456789123456789112345678912.........
那么你能告诉我在S串中的第N个数字是多少吗?
 

 

Input
输入首先是一个数字K,代表有K次询问。
接下来的K行每行有一个整数N(1 <= N < 2^31)。
 

 

Output
对于每个N,输出S中第N个对应的数字.
 

 

Sample Input
6
1
2
3
4
5
10
 

 

Sample Output
1
1
2
1
2
4
 
/*
串S的长度为S=1+2+3+4+...+n 
*/
#include<stdio.h> 
#include<string.h> 
#include<algorithm> 
using namespace std; 
__int64 i,j,k,l,m,n,t; 
int main() 
{ 
    scanf("%I64d",&k); 
    while(k--) 
    { 
        scanf("%I64d",&n); 
        for(i=1;;i++) 
        if(i*(i+1)/2>=n) //先求出n所在的位置是位于S串中第几部分(第一部分是S1=1,第二部分是S2=12第三部分是S3=123)
		                  //以此类推(i*(i+1)=1+2+3+...+i) 
        break; 
        m=n-i*(i-1)/2; //i*(i-1)/2为除Si串外其前边所有串的长度
		              //m为Si串中所要求的位置 
        m%=9; //因为每9个数循环一次所以求m%9的结果 
        if(m==0) 
        m=9; 
        printf("%I64d\n",m); 
    } 
} 

  

  

posted @ 2015-11-23 16:57  非我非非我  阅读(232)  评论(0编辑  收藏  举报