hdoj 2051 Bitset

Bitset

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14685    Accepted Submission(s): 11173


Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

 

Input
For each case there is a postive number n on base ten, end of file.
 

 

Output
For each case output a number on base two.
 

 

Sample Input
1
2
3
 

 

Sample Output
1
10
11
 
十进制转化为二进制  太水了
 
#include<stdio.h>
#include<math.h>
int main()
{
	int n,j,sum;
	while(scanf("%d",&n)!=EOF)
	{
		sum=0;j=0;
		while(n!=0)
		{
			sum=sum+((n%2)*pow(10,j++));
			n=n/2;
		}
		printf("%d\n",sum);
	}
	return 0;
}

  

 
posted @ 2015-03-29 14:04  非我非非我  阅读(178)  评论(0编辑  收藏  举报