NUC1742 Subsequence【前缀和+二分搜索+尺取法】

Subsequence

时间限制: 1000ms 内存限制: 65536KB

通过次数: 1总提交次数: 1

问题描述
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
输入描述
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
输出描述
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
样例输入
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
样例输出
2
3
来源
Southeastern Europe 2006


问题分析:(略)

这个问题和《POJ3061 ZOJ3123 Subsequence【前缀和+二分搜索+尺取法】》是同一个问题,代码直接用就AC了。

程序说明:参见参考链接。

参考链接:POJ3061 ZOJ3123 Subsequence【前缀和+二分搜索+尺取法】

题记:程序做多了,不定哪天遇见似曾相识的。

AC的C++程序如下:

/* POJ3061 ZOJ3123 Subsequence */

#include <iostream>
#include <algorithm>

using namespace std;

const int N = 100000;
int prefixsum[N+1];

int main()
{
    int t, n, s, val, ans;

    cin >> t;
    while(t--) {
        cin >> n >> s;

        // 输入数据,计算前缀和
        prefixsum[0] = 0;
        for(int i=1; i<=n; i++) {
            cin >> val;

            prefixsum[i] = prefixsum[i - 1] + val;
        }

        if(prefixsum[n] < s)
            ans = 0;
        else {
            ans = n;
            for(int i=0; prefixsum[i] + s < prefixsum[n]; i++) {
                int pos = lower_bound(prefixsum + i, prefixsum + n, prefixsum[i] + s) - prefixsum;
                ans = min(ans, pos - i);
            }
        }

        cout << ans << endl;
    }

    return 0;
}



posted on 2017-06-26 07:48  海岛Blog  阅读(310)  评论(0编辑  收藏  举报

导航