Bzoj3315 [Usaco2013 Nov]Pogo-Cow(luogu3089)

3315: [Usaco2013 Nov]Pogo-Cow

Time Limit: 3 Sec  Memory Limit: 128 MB
Submit: 352  Solved: 181
[Submit][Status][Discuss]

Description

In an ill-conceived attempt to enhance the mobility of his prize cow Bessie, Farmer John has attached a pogo stick to each of Bessie's legs. Bessie can now hop around quickly throughout the farm, but she has not yet learned how to slow down. To help train Bessie to hop with greater control, Farmer John sets up a practice course for her along a straight one-dimensional path across his farm. At various distinct positions on the path, he places N targets on which Bessie should try to land (1 <= N <= 1000). Target i is located at position x(i), and is worth p(i) points if Bessie lands on it. Bessie starts at the location of any target of her choosing and is allowed to move in only one direction, hopping from target to target. Each hop must cover at least as much distance as the previous hop, and must land on a target. Bessie receives credit for every target she touches (including the initial target on which she starts). Please compute the maximum number of points she can obtain.

一个坐标轴有N个点,每跳到一个点会获得该点的分数,并只能朝同一个方向跳,但是每一次的跳跃的距离必须不小于前一次的跳跃距离,起始点任选,求能获得的最大分数。

Input

* Line 1: The integer N.

* Lines 2..1+N: Line i+1 contains x(i) and p(i), each an integer in the range 0..1,000,000.

Output

* Line 1: The maximum number of points Bessie can receive.

Sample Input

6
5 6
1 1
10 5
7 6
4 8
8 10

INPUT DETAILS: There are 6 targets. The first is at position x=5 and is worth 6 points, and so on.

Sample Output

25
OUTPUT DETAILS: Bessie hops from position x=4 (8 points) to position x=5 (6 points) to position x=7 (6 points) to position x=10 (5 points).

从坐标为4的点,跳到坐标为5的,再到坐标为7和,再到坐标为10的。
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define maxn 101
int n,ans;
struct node{
    int s,v;
}a[maxn];
int cmp(node x,node y){return x.s<y.s;}
void dfs1(int now,int limit,int sum){
    ans=max(ans,sum);
    if(now>n)return;
    for(int i=now+1;i<=n;i++){
        if(a[i].s-a[now].s<limit)continue;
        else dfs1(i,a[i].s-a[now].s,sum+a[i].v);
    }
}
void dfs2(int now,int limit,int sum){
    ans=max(ans,sum);
    if(now<1)return;
    for(int i=now-1;i>=1;i--){
        if(a[now].s-a[i].s<limit)continue;
        else dfs2(i,a[now].s-a[i].s,sum+a[i].v);
    }
}
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++)scanf("%d%d",&a[i].s,&a[i].v);
    sort(a+1,a+n+1,cmp);
    for(int i=1;i<=n;i++){
        dfs1(i,0,a[i].v);//向右 
        dfs2(i,0,a[i].v);//向左 
    }
    printf("%d",ans);
}
36分 暴力
/*
    首先可以写出n^3dp的状态转移方程:f[i][j]=max{f[j][k]+val[i]},f[i][j]表示最后一步跳到点从j点跳到i点的最大价值(状态不能设成f[i],因为j对后面的决策是有影响的),然后枚举k转移,但这样在时限内是无法通过的,于是考虑如何优化dp,可以改变一下枚举顺序,也就是一般的都是先枚举i再枚举j,可以先枚举j再枚举i,这样有什么好处呢,那么k就以直接用一个指针从j-1扫到1,因为随着i的不断增加,i与j之间的距离是递增的,那么之前合法的决策现在也一定合法,那么就可以用一个值记录最大的f[j][k],转移即可。然后还要记得正反做两遍。
*/
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define maxn 1010
int n,dp[maxn][maxn],ans;
struct node{
    int pos,v;
}a[maxn];
int cmp(node x,node y){
    return x.pos<y.pos;
}
int cmp2(node x,node y){
    return x.pos>y.pos;
}
void work1(){
    for(int j=1;j<=n;j++){//从右往左跳 
        int k=j-1,val=dp[j][0]+a[j].v;
        for(int i=j+1;i<=n;i++){
            while(k&&a[i].pos-a[j].pos>=a[j].pos-a[k].pos)
                val=max(val,dp[j][k]+a[j].v),k--;
            dp[i][j]=max(dp[i][j],val);
            ans=max(ans,val+a[i].v);
        }
    }
}
void work2(){
    for(int j=n;j>=1;j--){
        int k=j+1,val=dp[j][n+1]+a[j].v;
        for(int i=j-1;i>=1;i--){
            while(k<n+1&&a[k].pos-a[j].pos<=a[j].pos-a[i].pos)
                val=max(val,dp[j][k]+a[j].v),k++;
            dp[i][j]=max(dp[i][j],val);
            ans=max(ans,val+a[i].v);
        }
    }
}
int main(){
    //freopen("Cola.txt","r",stdin);
    scanf("%d",&n);
    for(int i=1;i<=n;i++)scanf("%d%d",&a[i].pos,&a[i].v);
    sort(a+1,a+n+1,cmp);
    work1();
    work2();
    printf("%d",ans);
}
100分 单调队列优化dp
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define maxn 1010
int n,ans,dp[maxn][maxn],q[maxn][2],head,tail;
struct node{
    int pos,v;
}a[maxn];
int cmp1(node x,node y){return x.pos<y.pos;}
int cmp2(node x,node y){return x.pos>y.pos;}
void work(){
    for(int i=1;i<=n;i++){
        dp[i][i]=a[i].v;
        head=1,tail=0;
        for(int j=i-1;j>=1;j--){
            while(head<=tail&&q[tail][1]<=dp[i][j])tail--;
            q[++tail][0]=j;q[tail][1]=dp[i][j];
        }
        for(int j=i+1;j<=n;j++){
            dp[j][i]=a[i].v+a[j].v;
            while(head<=tail&&abs(a[q[head][0]].pos-a[i].pos)<abs(a[i].pos-a[j].pos))head++;
            if(head<=tail)dp[j][i]=max(dp[j][i],a[j].v+q[head][1]);
            ans=max(ans,dp[j][i]);
        }
    }
}
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++)scanf("%d%d",&a[i].pos,&a[i].v);
    sort(a+1,a+n+1,cmp1);
    work();
    sort(a+1,a+n+1,cmp2);
    work();
    printf("%d",ans);
    return 0;
}
100分 单调队列优化dp(另一种写法)

 

posted @ 2017-08-13 11:48  Echo宝贝儿  阅读(236)  评论(0编辑  收藏  举报