ICPC2008哈尔滨-E-Gauss Elimination

题目描述

Li Zhixiang have already been in “Friendship” ocean-going freighter for three months. The excitement has gradually disappeared. He stands on the board, holding the railing and watching the dazzling ocean in the sun silently. Day after day, the same scenery is monotonous and tasteless, even the merry seagulls following the freighter cannot arouse his interest. Hearing the footsteps behind, he turns back to see the old captain is coming towards him. The captain has understood his idea, however, he starts a new topic with the young man.

“Do you know how far our voyage is?” The captain asks. Li Zhixiang feels ashamed because he can not answer. Then the captain says with a smile, “5050 miles. Do you still remember the story of 5050?” This time the young man really blushes. The old captain continues saying:” You definitely know the story of 5050. When the German mathematician, “the prince of mathematicians”, Gauss was 10 years old …” Young man remembers this story and goes on to tell, “ When Gauss was 10 years old, he could add a list of integers from 1 to 100 in a few seconds, which shocked the teachers.” The old captain adds, “Gauss has many other stories like this. When he entered the university at the age of 17, he was able to construct heptadecagon by compass and straightedge. His university teachers were also impressed by his ability. Not only could college graduate students fail to do it, but also they felt hard to understand Gauss’s constructing process.” 

At this time, vice-captain greets the old captain. The old captain says to Li Zhixiang: “Come over to my office tonight, let’s continue the conversation.” It is still calm and tranquil in the evening. The freighter travels smoothly on the sea in the silver moonlight. The captain tells the young man the following words.

Among the mathematicians through the ages, there are three greatest mathematicians: Archimedes, Newton and Gauss. Most of Gauss’s mathematical achievements are difficult to understand. Nevertheless, there are some comparatively easy. For instance, when it comes to solving multivariate system of linear equations, there is a solution called “Gauss Elimination”. In the navigation business, many problems can be solved by “Gauss elimination”. If you are interested in it, I will show you a simple question. Try it.”

输入

There are several test cases. In the first line of each case, a number n indicates that there are n equations. The following n lines, each line has n+1 numbers, ai1,ai2,ai3…..ain, bi(1<= i <=n), these numbers indicate the coefficients of systems of the equations. ai1*x1+ai2*x2+......ain*xn=bi. Input is terminated by the end of file.

输出

For each given systems of equations, if there are solutions, output n solutions in the order of appearance in the equations(n<=100),  each solution number is in one line. If solution is not integer, show it in fraction. If no solution, output “No solution.” Leave a blank line after each case.

样例输入

2
1000000000000000000000000 1000000000000000000000000 1000000000000000000000000
-1000000000000000000000000 1000000000000000000000000 0
1
0 4

样例输出

1/2
1/2

No solution.
大数分数高斯消元 
import java.math.BigInteger;
import java.util.Scanner;
 
class Number{
    BigInteger a,b;
    Number() {
        a=BigInteger.valueOf(1);
        b=BigInteger.valueOf(1);
    }
     
    Number(BigInteger x,BigInteger y) {
        a=x;
        b=y;
    }
     
    Number sub(Number x){
        Number c=new Number();
        c.b=b.multiply(x.b);
        c.a=a.multiply(x.b).subtract(x.a.multiply(b));
        BigInteger d=c.a.gcd(c.b);
        if (d.compareTo(BigInteger.valueOf(0))!=0){
            c.a=c.a.divide(d); c.b=c.b.divide(d);
        }
        return c;
    }
     
    Number mul(Number x){
        Number c=new Number();
        c.b=b.multiply(x.b);
        c.a=a.multiply(x.a);
        BigInteger d=c.a.gcd(c.b);
        if (d.compareTo(BigInteger.valueOf(0))!=0){
            c.a=c.a.divide(d); c.b=c.b.divide(d);
        }
        return c;
    }
     
    Number div(Number x) {
        Number c=new Number();
        c.b=b.multiply(x.a);
        c.a=a.multiply(x.b);
        BigInteger d=c.a.gcd(c.b);
        if (d.compareTo(BigInteger.valueOf(0))!=0){
            c.a=c.a.divide(d); c.b=c.b.divide(d);
        }
        return c;
    }
     
    int com(Number x) {
        BigInteger p=a.multiply(x.b);
        BigInteger q=x.a.multiply(b);
        if (p.compareTo(BigInteger.valueOf(0))<0) p=p.multiply(BigInteger.valueOf(-1));
        if (q.compareTo(BigInteger.valueOf(0))<0) q=q.multiply(BigInteger.valueOf(-1));
         
        return p.compareTo(q);
    }
}
public class Main {
     
    public static boolean Guss(int n,Number a[][],Number b[]){
        int k=1,col=1;
        while (k<=n && col<=n) {
            int max_r=k;
            for (int i=k+1;i<=n;i++) 
                if (a[i][col].com(a[max_r][col])>0)
                    max_r=i;
            if (a[max_r][col].com(new Number(BigInteger.valueOf(0),BigInteger.valueOf(1)))==0) return false;
            if (k!=max_r) {
                for (int j=col;j<=n;j++) {
                    Number tmp=a[k][j];
                    a[k][j]=a[max_r][j];
                    a[max_r][j]=tmp;
                }
                Number tmp=b[k]; b[k]=b[max_r]; b[max_r]=tmp;
            }
             
            b[k]=b[k].div(a[k][col]);
            for (int j=col+1;j<=n;j++) a[k][j]=a[k][j].div(a[k][col]);
            a[k][col].a=BigInteger.valueOf(1);
            a[k][col].b=BigInteger.valueOf(1);
             
            for (int i=1;i<=n;i++) {
                if (i!=k) {
                    b[i]=b[i].sub(b[k].mul(a[i][col]));
                    for (int j=col+1;j<=n;j++) a[i][j]=a[i][j].sub(a[k][j].mul(a[i][col]));
                    a[i][col].a=BigInteger.valueOf(0);
                }
            }
            k++; col++;
        }
        return true;
    }
 
 
 
    public static void main(String[] args) {
        Number a[][] = new Number[105][105];
        Number b[] = new Number[105];
         
        for (int i=1;i<=100;i++) {
            for (int j=1;j<=100;j++) a[i][j]=new Number();
            b[i]=new Number();
        }
        int n;
        Scanner in = new Scanner(System.in);
        while (in.hasNext()) {
            n=in.nextInt();
            for (int i=1;i<=n;i++){
                for (int j=1;j<=n;j++){
                    a[i][j].a = in.nextBigInteger();
                    a[i][j].b = BigInteger.valueOf(1);
                }
                b[i].a=in.nextBigInteger();
                b[i].b=BigInteger.valueOf(1);
            }
             
            if (Guss(n,a,b)==true) {
                for (int i=1;i<=n;i++) {
                    BigInteger d=b[i].a.gcd(b[i].b);
                    if (d.compareTo(BigInteger.valueOf(0))!=0){
                        b[i].a=b[i].a.divide(d); b[i].b=b[i].b.divide(d);
                    }
                //  System.out.println(1+" "+b[i].b+" "+b[i].b.compareTo(BigInteger.valueOf(0)));
                    if (b[i].b.compareTo(BigInteger.valueOf(0))<0){
                    //  System.out.println("*");
                        b[i].b=b[i].b.multiply(BigInteger.valueOf(-1));
                        b[i].a=b[i].a.multiply(BigInteger.valueOf(-1));
                    }
                //  System.out.println(2+" "+b[i].b+" "+b[i].b.compareTo(BigInteger.valueOf(0)));
                    if (b[i].a.compareTo(BigInteger.valueOf(0))==0) b[i].b=BigInteger.valueOf(1);
                    if (b[i].b.compareTo(BigInteger.valueOf(1))==0) System.out.println(b[i].a);
                    else System.out.println(b[i].a+"/"+b[i].b);
                }
            } else System.out.println("No solution.");
             
            System.out.println();
        }
    }
}
View Code

 

 
posted @ 2019-08-07 20:26  特特w  阅读(198)  评论(0编辑  收藏  举报