hdu 1042 N! java大数及判断文件末尾

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 73503    Accepted Submission(s): 21308


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

 

Input
One N in one line, process to the end of file.
 

 

Output
For each N, output N! in one line.
 

 

Sample Input
1 2 3
 

 

Sample Output
1 2 6
 

 

Author
JGShining(极光炫影)
 
import java.io.*;
import java.math.BigInteger;
import java.util.*;
public class Main {

    public static void main(String[] args) {
        // TODO Auto-generated method stub
         Scanner cin=new Scanner (new BufferedInputStream(System.in));
            PrintWriter cout=new PrintWriter(System.out);
            int t;
            //t=cin.nextInt();
            //int eg=1;
            while(cin.hasNextInt())
            {
                t=cin.nextInt();
                BigInteger one=new BigInteger("1");
                BigInteger ans=one;
                BigInteger tmp =one;
                for(int i=0;i<t;i++){

                    ans=ans.multiply(tmp);
                    tmp=tmp.add(one);
                }
                //System.out.println(ans);
                System.out.println(ans);


            }
    }


}
View Code

直接java大数,注意要读到文件末尾就行。

posted @ 2016-05-21 10:58  超级学渣渣  阅读(260)  评论(0编辑  收藏  举报