A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 305856    Accepted Submission(s): 59088


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

 

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

 

Author
Ignatius.L
 

 

Recommend
We have carefully selected several similar problems for you:  1000 1001 1004 1003 1008
 
 
#include<string>
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int n;
    string a,b;
    while(~scanf("%d",&n))
    {
        int cas=1;
        for(int i=0; i<n; i++)
        {
            cin>>a>>b;
            int ans[10005];
            for(int i=0; i<1005; i++)
                ans[i]=0;
            int tmp=0;
            int len=(a.length()<b.length())?a.length():b.length();
            int llen=(a.length()>b.length())?a.length():b.length();
            int t=0;
            /* for(int i=llen-1, j=len-1; j>-1 ; i--,j--)
             {
                 if(a[i]-'0'+b[j]-'0'+tmp>9)
                 {
                     ans[t++]=a[i]-'0'+b[j]-'0'+tmp-10;
                     tmp=1;
                 }
                 else
                 {
                     ans[t++]=a[i]-'0'+b[j]-'0'+tmp;
                     tmp=0;
                 }
             }*/
            if(a.length()>=b.length())
            {
                for(int i=llen-1, j=len-1; j>-1 ; i--,j--)
                {
                    if(a[i]-'0'+b[j]-'0'+tmp>9)
                    {
                        ans[t++]=a[i]-'0'+b[j]-'0'+tmp-10;
                        tmp=1;
                    }
                    else
                    {
                        ans[t++]=a[i]-'0'+b[j]-'0'+tmp;
                        tmp=0;
                    }
                }
                for(int i=llen-len-1; i>-1; i--)
                {
                    if(tmp+a[i]-'0'>9)
                    {
                        ans[t++]=tmp-10+a[i]-'0';
                        tmp=1;
                    }
                    else
                    {
                        ans[t++]=a[i]+tmp-'0';
                        tmp=0;
                    }
                }
            }
            if(a.length()<b.length())
            {
                for(int j=llen-1, i=len-1; i>-1 ; i--,j--)
                {
                    if(a[i]-'0'+b[j]-'0'+tmp>9)
                    {
                        ans[t++]=a[i]-'0'+b[j]-'0'+tmp-10;
                        tmp=1;
                    }
                    else
                    {
                        ans[t++]=a[i]-'0'+b[j]-'0'+tmp;
                        tmp=0;
                    }
                }
                for(int i=llen-len-1; i>-1; i--)
                {
                    if(tmp+b[i]-'0'>9)
                    {
                        ans[t++]=tmp-10+b[i]-'0';
                        tmp=1;
                    }
                    else
                    {
                        ans[t++]=b[i]+tmp-'0';
                        tmp=0;
                    }
                }
            }
            if(tmp!=0) ans[t++]=tmp;
            cout<<"Case "<<cas++<<":"<<endl<<a<<" + "<<b<<" = ";
            for(int i=t-1; i>-1; i--) cout<<ans[i];
            if(i!=n-1)
            printf("\n\n");
            else printf("\n");
        }
    }
    return 0;
}
View Code

 

posted @ 2016-04-28 23:52  超级学渣渣  阅读(205)  评论(0编辑  收藏  举报