HDU 4730 We Love MOE Girls

We Love MOE Girls

Time Limit: 1000/500 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 44 Accepted Submission(s): 37


Problem Description
Chikami Nanako is a girl living in many different parallel worlds. In this problem we talk about one of them.
In this world, Nanako has a special habit. When talking with others, she always ends each sentence with "nanodesu".
There are two situations:
If a sentence ends with "desu", she changes "desu" into "nanodesu", e.g. for "iloveyoudesu", she will say "iloveyounanodesu". Otherwise, she just add "nanodesu" to the end of the original sentence.
Given an original sentence, what will it sound like aften spoken by Nanako?
 

 

Input
The first line has a number T (T <= 1000) , indicating the number of test cases.
For each test case, the only line contains a string s, which is the original sentence.
The length of sentence s will not exceed 100, and the sentence contains lowercase letters from a to z only.
 

 

Output
For every case, you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output which Nanako will say.
 

 

Sample Input
2 ohayougozaimasu daijyoubudesu
 

 

Sample Output
Case #1: ohayougozaimasunanodesu Case #2: daijyoubunanodesu
 

 

Source
 


 

 

import java.io.*;
import java.util.*;
public class Main {
	BufferedReader bu;
	PrintWriter pw;
	int t;
	public static void main(String[] args) throws Exception{
		new Main().work();
	}
	void work() throws Exception{
		bu=new BufferedReader(new InputStreamReader(System.in));
		pw=new PrintWriter(new OutputStreamWriter(System.out),true);
		t=Integer.parseInt(bu.readLine());
		for(int p=1;p<=t;p++){
			pw.print("Case #"+p+": ");
			String s=bu.readLine();
			StringBuffer bu=new StringBuffer(s);
			String s1="";
			if(s.endsWith("desu")){
				int index=s.lastIndexOf('d');
				bu.replace(index,s.length(),"");
			}
				bu.append("nanodesu");
			pw.println(bu.toString());
		}
		
	}
}


 

 

posted on 2013-09-15 19:49  新一  阅读(262)  评论(0编辑  收藏  举报

导航