ZOJ 3207 80ers' Memory(strcmp函数的用法)

80ers' Memory

Time Limit: 1 Second      Memory Limit: 32768 KB

I guess most of us are so called 80ers, which means that we were born in the 1980's. This group of people shared a lot of common memories. For example, the Saint Seiya, the YoYo ball, the Super Mario, and so on. Do you still remember these?

Input

There will be ONLY ONE test case.

The test case begins with a positive integer N, (N < 100).
Then there will be N lines each containing a single word describing a keyword of the typical 80ers' memories. Each word consists of letters, [a-zA-Z], numbers, [0-9], and the underline, '_'. The length of each word would be no more than 20.
Then one line follows with a positive integer K, (K < 100).
The last part of the test case will be K lines. The i-th line contains the keywords given by the i-th person and starts with a positive integer Ni. Then there will be Ni words separated by white spaces. Each of these words has no more than 20 characters.
All the words are case sensitive.

Output

For each of these K people, you are asked to count the number of typical 80ers' keywords on his/her list and output it in a single line.

Sample Input

4
Saint_Seiya
YoYo_ball
Super_Mario
HuLuWa
3
2 Saint_Seiya TiaoFangZi
1 KTV
3 HuLuWa YOYO_BALL YoYo_ball

Sample Output

1
0
2

Author: GAO, Fei
Source: The 6th Zhejiang Provincial Collegiate Programming Contest

 

 

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char str[105][25];
int n,k;
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        scanf("%s",&str[i]);
    scanf("%d",&k);
    for(int i=1;i<=k;i++)
    {
        int x,ans=0;
        scanf("%d",&x);
        for(;x>0;x--)
        {
            char ch[25];
            scanf("%s",&ch);
            for(int j=1;j<=n;j++)
            if (!strcmp(ch,str[j])) {ans++; break;}
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

posted on 2017-02-15 14:00  Yxter  阅读(246)  评论(0编辑  收藏  举报

导航