[ACM]Function Run Fun

Problem Description

We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1 

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

思路:本题如果按照题目中的那样递归是肯定超时的,因此要想另一种方法,有三个变量a,b,c, 可以想到用三维数组w[i] [j] [k] ,把所有的数据都封装在一个正方体里面,这个正方体已经存满了数据,当我们输入a b c时,只要对应到正方体数据库里一一对应就行了,这是一种用空间换时间的方法。

代码:

#include <iostream>

using namespace std;
int main()
{
    int w[21][21][21];//要比20大
    int i,j,k;
    for(i=0;i<21;i++)
        for(j=0;j<21;j++)
            w[i][j][0]=1;
    for(i=0;i<21;i++)
        for(k=0;k<21;k++)
            w[i][0][k]=1;
    for(j=0;j<21;j++)
        for(k=0;k<21;k++)
            w[0][j][k]=1;//对应题目中的if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:1 
    for(i=1;i<21;i++)
        for(j=1;j<21;j++)
            for(k=1;k<21;k++)
                if(i<j&&j<k)
                    w[i][j][k]=w[i][j][k-1]+w[i][j-1][k-1]-w[i][j-1][k];
                    else
                        w[i][j][k]=w[i-1][j][k]+w[i-1][j-1][k]+w[i-1][j][k-1]-w[i-1][j-1][k-1];//把正方体填满数据
   int a,b,c;
   while(cin>>a>>b>>c&&(a!=-1||b!=-1||c!=-1))
   {
       if(a<=0||b<=0||c<=0)
        cout<<"w("<<a<<", "<<b<<", "<<c<<") = "<<"1"<<endl;
       else if(a>20||b>20||c>20)
        cout<<"w("<<a<<", "<<b<<", "<<c<<") = "<<w[20][20][20]<<endl;//对应if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:w(20, 20, 20)
       else
        cout<<"w("<<a<<", "<<b<<", "<<c<<") = "<<w[a][b][c]<<endl;//对应正方体中的数


   }
    return 0;
}

运行截图:




posted @ 2013-05-21 14:37  同学少年  阅读(224)  评论(0编辑  收藏  举报