卸载mysql时,提示libmysqlclient.so.16()(64bit) is needed by (installed) postfix

卸载时,提示错误,用这个命令就可以rpm -e --nodeps mysql-libs-5.1.73-5.el6_6.x86_64(这个是自己要卸载的版本)

 

 

 

[root@unaryhost dev]# rpm -ev mysql-libs-5.1.73-5.el6_6.x86_64
error: Failed dependencies:
libmysqlclient.so.16()(64bit) is needed by (installed) postfix-2:2.6.6-6.el6_5.x86_64
libmysqlclient.so.16(libmysqlclient_16)(64bit) is needed by (installed) postfix-2:2.6.6-6.el6_5.x86_64
mysql-libs is needed by (installed) postfix-2:2.6.6-6.el6_5.x86_64
[root@unaryhost dev]# rpm -qa | grep -i mysql
mysql-libs-5.1.73-5.el6_6.x86_64
[root@unaryhost dev]# rpm -e --nodeps mysql-libs-5.1.73-5.el6_6.x86_64
warning: /etc/my.cnf saved as /etc/my.cnf.rpmsave
[root@unaryhost dev]# rpm -qa | grep -i mysql
[root@unaryhost dev]#

 

 

有时间,可以这样试一下,我忘记尝试了。

--nodeps就是安装时不检查依赖关系,比如你这个rpm需要A,但是你没装A,这样你的包就装不上,用了--nodeps你就能装上了。--force就是强制安装,比如你装过这个rpm的版本1,如果你想装这个rpm的版本2,就需要用--force强制安装

 

posted on 2019-05-27 17:21 神通停客 阅读(...) 评论(...) 编辑 收藏

导航

统计