PTA 1102 Invert a Binary Tree (25 分)(死都不建树是懒狗最后的倔强)

1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.
Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

感悟

宁愿对着题目多想一会都不要去建树,写出来的代码又臭又长,递归的代码又短看着又有水平,狗都不建树.
突然之间发现树的题目也能写的得心应手了,之前建树也写的跌跌碰碰,现在也能和柳神一样用递归写了,感触良多啊.

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
const int N = 2010;
int n,root,cnt,flag1,flag2;
int st[N];
vector<int> a[N];
struct Node 
{
    int l, r;
}node[N];

void level_order(int x, int level)
{
    a[level].push_back(x);
    if(node[x].l != -1) level_order(node[x].l, level + 1);   
    if(node[x].r != -1) level_order(node[x].r, level + 1);
}

void in_order(int x)
{
    if(node[x].l != -1) in_order(node[x].l);   
    if(flag2++)printf(" ");
    printf("%d",x);
    if(node[x].r != -1) in_order(node[x].r);
    
}

int main()
{
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
    {
        char x, y;
        scanf(" %c %c",&y,&x);
        if(x == '-') node[i].l = -1;
        else node[i].l = x - '0',st[node[i].l] = 1;
        if(y == '-') node[i].r = -1;
        else node[i].r = y - '0',st[node[i].r] = 1;
    }
    while(st[root])root++;
    level_order(root,0);
    for(int i = 0; i < n; i++)
        for(auto x:a[i])
        {
            if(flag1++) printf(" ");
            printf("%d", x);
        }
    puts("");
    in_order(root);
            
    return 0;
}
posted @ 2022-03-03 03:29  别问了我什么都不会  阅读(20)  评论(0编辑  收藏  举报