BZOJ 2763

2763: [JLOI2011]飞行路线

Time Limit: 10 Sec  Memory Limit: 128 MB
Submit: 2073  Solved: 790
[Submit][Status][Discuss]

Description

Alice和Bob现在要乘飞机旅行,他们选择了一家相对便宜的航空公司。该航空公司一共在n个城市设有业务,设这些城市分别标记为0到n-1,一共有m种航线,每种航线连接两个城市,并且航线有一定的价格。Alice和Bob现在要从一个城市沿着航线到达另一个城市,途中可以进行转机。航空公司对他们这次旅行也推出优惠,他们可以免费在最多k种航线上搭乘飞机。那么Alice和Bob这次出行最少花费多少?

Input

数据的第一行有三个整数,n,m,k,分别表示城市数,航线数和免费乘坐次数。
第二行有两个整数,s,t,分别表示他们出行的起点城市编号和终点城市编号。(0<=s,t<n)
接下来有m行,每行三个整数,a,b,c,表示存在一种航线,能从城市a到达城市b,或从城市b到达城市a,价格为c。(0<=a,b<n,a与b不相等,0<=c<=1000)
 

Output

 
只有一行,包含一个整数,为最少花费。

Sample Input

5 6 1
0 4
0 1 5
1 2 5
2 3 5
3 4 5
2 3 3
0 2 100

Sample Output

8

HINT

 

对于30%的数据,2<=n<=50,1<=m<=300,k=0;


对于50%的数据,2<=n<=600,1<=m<=6000,0<=k<=1;


对于100%的数据,2<=n<=10000,1<=m<=50000,0<=k<=10.


 

 

Source

 题解:

分层图最短路

每个点的意义是走到第i个点,已经免费了k次的最少花费,建图就比较显然了。注意这道题建图只需要建一层,然后手写转移,这样比较快。

f[i][j]表示从起点开始,使用i次免费机会,到达j点的最小消费值。

ps:要加堆优化,否则会T。

 AC代码:
#include<cstdio>
#include<cstring>
#include<queue>
#include<iostream>
using namespace std;
const int N=1e5+10;
int n,m,k,from,to,tot,v[N],w[N],head[N],next[N],f[11][N];
bool vis[11][N];
struct node{
    int step,p;
    bool operator <(const node &a)const {return f[step][p]>f[a.step][a.p];}
};
inline void add(int x,int y,int z){
    v[++tot]=y;w[tot]=z;next[tot]=head[x];head[x]=tot;
}
inline void spfa(){
    static priority_queue<node>que;
    memset(f,127/3,sizeof f);
    que.push((node){0,from});
    f[0][from]=0;
    while(!que.empty()){
        node h=que.top();que.pop();
        int x=h.p,step=h.step;
        vis[step][x]=0;
        for(int i=head[x];i;i=next[i]){
            if(f[step][v[i]]>f[step][x]+w[i]){
                f[step][v[i]]=f[step][x]+w[i];
                if(!vis[step][v[i]]){
                    vis[step][v[i]]=1;
                    que.push((node){step,v[i]});
                }
            }
            if(f[step+1][v[i]]>f[step][x]&&step<k){
                f[step+1][v[i]]=f[step][x];
                if(!vis[step+1][v[i]]){
                    vis[step+1][v[i]]=1;
                    que.push((node){step+1,v[i]});
                }
                 
            }
        }
    }
}
int main(){
    scanf("%d%d%d",&n,&m,&k);
    scanf("%d%d",&from,&to);from++;to++;
    for(int i=1,x,y,z;i<=m;i++) scanf("%d%d%d",&x,&y,&z),x++,y++,add(x,y,z),add(y,x,z);
    spfa();
    int ans=0x7fffffff;
    for(int i=0;i<=k;i++) ans=min(ans,f[i][to]);
    printf("%d\n",ans);
    return 0;
}

 

posted @ 2016-07-29 17:37  神犇(shenben)  阅读(271)  评论(0编辑  收藏  举报