POJ 3461 Oulipo[附KMP算法详细流程讲解]

 
E - Oulipo
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0



 

hash_AC代码:

 

/*
Problem: 3461        User: bbsh
Memory: 5296K        Time: 110MS
Language: G++        Result: Accepted
*/
#include<cstdio>
#include<cstring>
using namespace std;
const int N=1e6+5;
typedef int i64;
i64 S,chk,p,P,hash_key[N];
char s1[N],s2[N];
int cas,l1,l2,ans;
inline i64 fpow(i64 a,i64 p){
    i64 res=1;
    for(;p;p>>=1,a=a*a) if(p&1) res=res*a;
    return res;
}
inline void get_s2_key(){
    p=fpow(P,l2);S=0;
    for(int i=1;i<=l2;i++) S=S*P+s2[i]-'A';
}
inline void get_s1_key(){
    hash_key[0]=0;
    for(int i=1;i<=l1;i++) hash_key[i]=hash_key[i-1]*P+s1[i]-'A';
}
inline i64 query(int x,int y){
    return hash_key[y]-hash_key[x-1]*p;
}
int main(){
    P=29;//prime_num
    for(scanf("%d",&cas);cas--;){
        scanf("%s%s",s2+1,s1+1);ans=0;
        l1=strlen(s1+1);l2=strlen(s2+1);
        get_s2_key();
        get_s1_key();
        for(int i=l2;i<=l1;i++){
            chk=query(i-l2+1,i);
            if(chk==S) ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

 

 

KMP_AC代码:

/*
Problem: 3461        User: bbsh
Memory: 1424K        Time: 110MS
Language: G++        Result: Accepted
Source Code
*/
#include<cstdio>
#include<cstring>
using namespace std;
const int N=1e6+5;
char s1[N],s2[N];
int cas,l1,l2,fail[N];
void get_next(){
    int p=0;fail[1]=0;
    for(int i=2;i<=l2;i++){
        while(p>0&&s2[i]!=s2[p+1]) p=fail[p];
        if(s2[i]==s2[p+1]) p++;
        fail[i]=p;
    }
}
void kmp(){
    int p=0,ans=0;
    for(int i=1;i<=l1;i++){
        while(p>0&&s1[i]!=s2[p+1]) p=fail[p];
        if(s1[i]==s2[p+1]) p++;
        if(p==l2) ans++,p=fail[p];
    }
    printf("%d\n",ans);
}
int main(){
    for(scanf("%d",&cas);cas--;){
        scanf("%s%s",s2+1,s1+1);
        l1=strlen(s1+1);l2=strlen(s2+1);
        get_next();
        kmp();
    }
    return 0;
}

 

 

附KMP算法详细流程讲解

  移步shenben's documents system

 

 

posted @ 2016-05-04 21:48  神犇(shenben)  阅读(509)  评论(0编辑  收藏  举报