HDU 1005 Number Sequence

 

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 86958    Accepted Submission(s): 20667


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

 

Output
For each test case, print the value of f(n) on a single line.
 

 

Sample Input
1 1 3 1 2 10 0 0 0
 

 

Sample Output
2 5
 

 

Author
CHEN, Shunbao
 

 

Source
 

解题思路:注意是对7求余,又因为 f[n] 只与f[n-1]与f[n-2]有关,所以当f[n-1]与f[n-2]出现重复时就是一个循环周期出现了,所以这题很好解了,分析一下循环周期的话,f[n-1]与f[n-2]最多49个状态必然出现重复了。

 


代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
using namespace std;

int a,b,n,f[110],t,pos;

void ini(){
	f[1]=1,f[2]=1;
	pos=n,t=n;
	for(int i=3;i<=n;i++){
		f[i]=(a*f[i-1]+b*f[i-2])%7;
		for(int j=i-1;j>=2;j--){
			if(f[j]==f[i] && f[j-1]==f[i-1]){
				t=i-j;
				pos=j;
				return;
			}
		}
	}
}

void computing(){
	if(n<=pos+t) cout<<f[n]<<endl;
	else cout<<f[(n-pos)%t+pos]<<endl;
}

int main(){
	while(scanf("%d%d%d",&a,&b,&n)!=EOF && (a||b||n)){
		ini();
		computing();
	}
	return 0;
}

 

 





 

posted on 2013-10-31 21:04  you Richer  阅读(202)  评论(0编辑  收藏  举报