[!] CocoaPods could not find compatible versions for pod "Folly"问题举例

$ pod install 后出现下面错误:

[!] CocoaPods could not find compatible versions for pod "Folly":

  In snapshot (Podfile.lock):

    Folly (from `./RNComponent/node_modules/react-native/third-party-podspecs/Folly.podspec`)

  In Podfile:

    Folly (from `./RNComponent/node_modules/react-native/third-party-podspecs/Folly.podspec`)

    React/CxxBridge (from `./RNComponent/node_modules/react-native`) was resolved to 0.57.5, which depends on

      Folly (= 2016.10.31.00)

 以为是cocoapods 版本高了,用低版本的试试

$ pod _1.1.1_ install  ,依然报错

[!] Unable to satisfy the following requirements: 

- `Folly (from `./RNComponent/node_modules/react-native/third-party-podspecs/Folly.podspec`)` required by `Podfile`

- `Folly (= 2016.10.31.00)` required by `React/CxxBridge (0.57.5)`

仔细看下错误原因,发现 CxxBridge 应该去掉,去掉即可

 

posted @ 2019-01-30 15:57  yoowei  阅读(6678)  评论(0编辑  收藏  举报