Android 9.0/P 版本推荐使用 HttpURLConnection

早在几年前,谷歌就推荐在Android2.3版本以上使用HttpURLConnection,而在即将正式发布的 Android P 版本中,谷歌彻底取消了对Apache HTTPClient的支持,针对此更改,开发者该如何正确适配 Android P ?

一、背景

1.参考谷歌提供的 Android P 版本变更说明文档:

https://developer.android.com/preview/behavior-changes#apache-nonp

https://developer.android.com/preview/behavior-changes#apache-p

2.Android 6.0 版本已移除对 Apache HTTP 客户端的支持

https://developer.android.com/about/versions/marshmallow/android-6.0-changes

Android 6.0 版本移除了对Apache HTTP客户端的支持。如果您的应用使用该客户端,并以 Android 2.3(API 级别为9)或更高版本为目标平台,请改用 HttpURLConnection 类。此API效率更高,能够通过透明压缩和响应缓存减少网络使用,并可最大限度降低耗电量。要继续使用 Apache HTTP API,须先在 build.gradle 文件中声明以下编译时依赖项:

android {
    useLibrary 'org.apache.http.legacy'
}

3.P版本修改

Remove org.apache.http.legacy from bootclasspath

从Android P开始,org.apache.http.legacy 库将从 bootclasspath 中删除。

(1). 修改对 TargetSdkVersion<P 的应用的影响

该修改对大多数 TargetSdkVersion<P 的应用都无影响,但是如果应用使用了系统 ClassLoader加载org.apache.http.*中的类时,将在Android P上发生 NoClassDefFoundError 失败,因为系统ClassLoader不再知道这些类。为了防止将来出现类似的问题,应用应该通过应用 ClassLoader 加载类,而不是直接访问系统ClassLoader。

(2). 修改对 TargetSdkVersion>=P 的应用的影响

对所有 TargetSdkVersion>=P 的应用,如果还是按照以前一样通过在 build.gradle 文件中声明以下编译时依赖项:\

android {
    useLibrary 'org.apache.http.legacy'
}

想继续使用 Apache-http 接口,都会出现 Apache-http 接口找不到的异常: 

二、适配指导

1.继续使用Apache-http

(1). TargetSdkVersion<P 的应用适配指导

方案一:不要使用非标准的 ClassLoader 。

方案二:应用可以自己添加依赖的 apache jar 包到工程 libs 目录规避该兼容性问题。

 
 

注意:对于最低 SDK为23或更低的应用程序,android:required=“false”属性是必需的,因为在 API 等级低于24的设备上,org.apache.http.legacy 库不可用。(在这些设备上,Apache HTTP 类在 bootclasspath 上可用。)

(2). TargetSdkVersion>=P 的应用适配指导

对于 TargetSdkVersion>=P的应用如果想继续使用Apache-http客户端,需要在应用的 AndroidManifest.xml 文件中添加:

<uses-libraryandroid:name="org.apache.http.legacy"android:required="false"/>

2.不再使用Apache-http客户端

使用 HttpURLConnection 替代 Apache-http。

posted @ 2018-10-16 15:36  灰色飘零  阅读(...)  评论(...编辑  收藏