11 2017 档案

摘要:一.删除的表恢复 flashback table tablename to before drop 二.恢复数据库到某段时间(注意清空的数据不能恢复)查找行移动有没有开启,修改行移动开启 select a.row_movement from user_tables where a.table_nam 阅读全文
posted @ 2017-11-30 18:15 存在的痕迹 阅读(690) 评论(0) 推荐(0)
摘要:从库启动到mount状态: SQL>SHUTDOWN IMMEDIATE SQL>STARTUP MOUNT; SQL>ALTER DATABASE RECOVER MANAGED STANDBY DATABASE USEING CURRENT LOGFILE DISCONNECT FROM SES 阅读全文
posted @ 2017-11-28 16:47 存在的痕迹 阅读(357) 评论(0) 推荐(0)
摘要:top +1显示CPU个数 shutdown -r now 重启linux crontab -e 0 5 * * * /root/bin/backup.sh>/home/Oracle/123.txt service crond restart(重启服务需要root权限)可以生成一个123.txt 阅读全文
posted @ 2017-11-26 22:32 存在的痕迹 阅读(143) 评论(0) 推荐(0)
摘要:oracle 11g中 内存用了自动化管理 MEMORY_TARGET的值大于/dev/shm 就会报错 ORA-00845: MEMORY_TARGET not supported on this system错误, redhat系列系统中,/dev/shm的默认值是系统总内存的一半 alter 阅读全文
posted @ 2017-11-26 21:47 存在的痕迹 阅读(199) 评论(0) 推荐(0)
摘要:win+r calc 计算器 shutdown -r -t 0 重启 shutdown -s -t 0关机 阅读全文
posted @ 2017-11-25 22:38 存在的痕迹 阅读(116) 评论(0) 推荐(0)
摘要:dategurd 安装碰到的一次ORA_27101 前不久在安装数据库同步的时候 主备库都已经能够正常同步 在使用 plsql 连接主库的时候出现ORA_27101,找了半天还以为datagurd 安装时候出现问题,但是两个数据库都能正常启动,监听也正常开启 listener.ora 文件LISTE 阅读全文
posted @ 2017-11-25 21:02 存在的痕迹 阅读(202) 评论(0) 推荐(0)
摘要:oracle 优化的规则有RBO(基于损耗) CBO( 基于规则)1.用什么工具监控oracle的性能2.oracel的执行计划 3.注意where语句的连接顺序 对于大数据量的语句放置在末尾 尤其是“主键ID=?”(现在oracle好像没有严格要求) 4.避免使用select * from 这样的 阅读全文
posted @ 2017-11-23 14:33 存在的痕迹 阅读(210) 评论(0) 推荐(0)