POJ 2155 Matrix 二维树状数组

Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 19174   Accepted: 7207

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Note
这是一个二维的树状数组,区间更新,单点查询
#include <queue>
#include <stack>
#include <math.h>
#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include <limits.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int MAX = 1010;
int c[MAX][MAX];
int n;
int a,b,e,d;
int Lowbit(int x)
{
    return x & (-x);
}
void Updata(int x,int y,int z)
{
    int i,k;
    for(i=x; i<=n; i+=Lowbit(i))
        for(k=y; k<=n; k+=Lowbit(k))
            c[i][k]+=z;
}

int Get(int x,int y)
{
    int i,k,sum = 0;
    for(i=x; i>0; i-=Lowbit(i))
        for(k=y; k>0; k-=Lowbit(k))
            sum += c[i][k];
    return sum;
}

int main()
{
    int x;
    scanf("%d",&x);
    while(x--)
    {
        memset(c,0,sizeof(c));
        int q;
        scanf("%d%d",&n,&q);
        char s;
        while(q--)
        {
            //cout<<q<<endl;
            scanf(" %c",&s);
            if(s=='C')
            {
                scanf("%d%d%d%d",&a,&b,&e,&d);
                a++,b++,e++,d++;
                Updata(e,d,1);
                Updata(a-1,d,-1);
                Updata(e,b-1,-1);
                Updata(a-1,b-1,1);
            }
            if(s=='Q')
            {
                scanf("%d%d",&a,&b);
                printf("%d\n",Get(a,b)%2);
            }
        }
        if(x!=0)
            printf("\n");
    }
    return 0;
}

 

posted @ 2014-12-05 00:43  qscqesze  阅读(247)  评论(0编辑  收藏  举报