UVA 10200 Prime Time (打表)

Prime Time

Euler is a well-known matematician, and, among many other things, he discovered that the formula n 2 + n + 41 produces a prime for 0 ≤ n < 40. For n = 40, the formula produces 1681, which is 41 ∗ 41. Even though this formula doesn’t always produce a prime, it still produces a lot of primes. It’s known that for n ≤ 10000000, there are 47,5% of primes produced by the formula! So, you’ll write a program that will output how many primes does the formula output for a certain interval.

Input

Each line of input will be given two positive integer a and b such that 0 ≤ a ≤ b ≤ 10000. You must read until the end of the file.

Output

For each pair a, b read, you must output the percentage of prime numbers produced by the formula in this interval (a ≤ n ≤ b) rounded to two decimal digits.

 

Sample Input

0 39

0 40

39 40

 

Sample Output

100.00

97.56

50.00

 

题目大意:

 

n可根据公式 f(n) = n*n+n+41得到f(n),f(n)可能是素数也可能不是素数,求a到b之间的数可根据公式得到素数的百分比

打表即可

 

#include<stdio.h>
#include<math.h>
#include<algorithm>
#include<string.h>
#include<stdlib.h>

using namespace std;

const int N = 10010;
typedef long long ll;

int num[N];//num[i]表0到i这个数之间的数可根据公式得到素数的数有多少个

int judge(int n)
{
    int k = sqrt(n);
    for(int i = 2 ; i <= k ; i++)
    {
        if(n % i == 0)
            return 0;
    }
    return 1;
}

int main()
{
    int a, b;
    memset(num, 0, sizeof(num));
    num[0] += judge(41);
    for(int i = 1 ; i < N ; i++)
        num[i] = num[i - 1] + judge(i * i + i + 41);
    while(~scanf("%d%d", &a, &b))
    {
        int sum1, sum;
        sum1 = num[b] - num[a] + judge(a * a + a + 41);
        sum = b - a + 1;
        printf("%.2f\n", (1.0 * sum1 / sum) * 100 + 1e-8);
    }
    return 0;
}

 

posted @ 2015-11-20 17:26  午夜阳光~  阅读(476)  评论(0编辑  收藏  举报