POJ Wormholes (SPFA)

http://poj.org/problem?id=3259

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
 
 

SPFA判断是否有负权,如果一个点进入队列的次数达到总点数则说明有负权

dist[i]数组记录源点到i的最短路径,与Dijsktar不同的是dist[i]多次更新

use[i]记录i点进入队列的次数,即dist[i]被更新的次数;

vis[i]标记i点是否进入队列

 

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<vector>
#include<queue>
#define INF 0xffffff
#define N 520
using namespace std;

struct node
{
    int e, w;
};

vector<node>G[N];
int n, use[N], dist[N];
bool vis[N];

void Init()
{
    int i;
    memset(vis, false, sizeof(vis));
    memset(use, 0, sizeof(use));
    for(i = 0 ; i <= n ; i++)
    {
        G[i].clear();
        dist[i] = INF;
    }
}

int SPFA(int s)
{
    queue<node>Q;
    node now, next;
    int i, len;
    now.e = s;
    now.w = 0;
    dist[s] = 0;
    Q.push(now);
    vis[s] = true;
    use[now.e]++;
    while(!Q.empty())
    {
        now = Q.front();
        Q.pop();
        vis[now.e] = false;

        len = G[now.e].size();
        for(i = 0 ; i < len ; i++)
        {
            next = G[now.e][i];
            if(dist[next.e] > dist[now.e] + next.w)
            {
                dist[next.e] = dist[now.e] + next.w;
                use[next.e]++;
                if(use[next.e] >= n)
                    return 1;
                if(!vis[next.e])
                {
                    vis[next.e] = true;
                    Q.push(next);
                }
            }
        }
    }
    return 0;
}

int main()
{
    int T, m, w, s, e, t, i;
    node p;
    scanf("%d", &T);
    while(T--)
    {

        scanf("%d%d%d", &n, &m, &w);
        Init();
        for(i = 1 ; i <= m ; i++)
        {
            scanf("%d%d%d", &s, &e, &t);
            p.w = t;
            p.e = s;
            G[e].push_back(p);
            p.e = e;
            G[s].push_back(p);
        }
        for(i = 1 ; i <= w ; i++)
        {
            scanf("%d%d%d", &s, &e, &t);
            p.w = -t;
            p.e = e;
            G[s].push_back(p);
        }
        if(SPFA(1))
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

 

posted @ 2015-07-21 10:07  午夜阳光~  阅读(209)  评论(0编辑  收藏  举报