HDU 1325 Is It A Tree?

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33012 Accepted Submission(s): 7552

Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output
For each test case display the line Case k is a tree." or the line Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1

Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source
North Central North America 1997

Recommend
Ignatius.L | We have carefully selected several similar problems for you: 1856 1232 1213 1863 1879

Statistic | Submit | Discuss | Note


【思路】:这是一个水题,虽然我第一眼感觉要并查集,
然后我看了一下,猜了个结论:只存在一个入度为0的点,其他点的入度不能大于1
然后顺手一交Accept

#include <bits/stdc++.h>
using namespace std;
const int MAXN = 100005;
int in[MAXN], out[MAXN], vids[MAXN];
bool judge(int n){
    int f1 = 0;
    for(int i = 1; i <= n; i ++){
        if(vids[i]){
            if(in[i] == 0){
                if(++ f1 > 1) return false;
            }
            if(in[i] > 1) return false;
        }
    }
    return true;
}
int main(){
    int a, b, step = 0, maxs = 0;
    while(~scanf("%d%d", &a, &b)){
        if(a == -1 && b == -1) break;
        else if(a == 0 && b == 0){
            step ++;
            if(judge(maxs)) printf("Case %d is a tree.\n", step);
            else printf("Case %d is not a tree.\n", step);
            memset(in, 0, sizeof(in));
            memset(out, 0, sizeof(out));
            memset(vids, 0, sizeof(vids));
        }
        else{
            in[b] ++, out[a] ++;
            vids[a] ++, vids[b] ++;
            maxs = max(maxs, a);
            maxs = max(maxs, b);
        }
    }
    return 0;
}
posted @ 2019-06-07 19:03  moxin0509  阅读(126)  评论(0编辑  收藏  举报