hdoj--1495--非常可乐(搜索+隐式图)

非常可乐

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7990    Accepted Submission(s): 3190


Problem Description
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。
 

Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。
 

Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
 

Sample Input
7 4 3 4 1 3 0 0 0
 

Sample Output
NO 3
 

Author
seeyou



#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
int vis[110][110],a[4];
struct node
{
	int v[4],step; 
};
int jud(int x,int y,int z,int w)
{
	if(x==w&&y==w)
	return 1;
	if(x==w&&z==w)
	return 1;
	if(y==w&&z==w)
	return 1;
	return 0;
}
void bfs()
{
	int w=a[0]/2;
	node now,next;
	memset(vis,0,sizeof(vis));
	queue<node>q;
	now.v[0]=a[0];
	now.v[1]=now.v[2]=now.step=0;
	vis[a[0]][0]=1;
	q.push(now);
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		for(int i=0;i<3;i++)
		{
			for(int j=0;j<3;j++)
			{
				if(i!=j)
				{
					next=now;
					if(now.v[i]+now.v[j]>a[j])
					{
						next.v[i]=now.v[i]+now.v[j]-a[j];
						next.v[j]=a[j];
						next.step=now.step+1;
					}
					else
					{
						next.v[i]=0;
						next.v[j]=now.v[i]+now.v[j];
						next.step=now.step+1;
					}
					if(jud(next.v[0],next.v[1],next.v[2],w))
					{
						printf("%d\n",next.step);
						return ;
					}
					if(!vis[next.v[0]][next.v[1]])
					{
						q.push(next);
						vis[next.v[0]][next.v[1]]=1;
					}
				}
			}
		}
	}
	printf("NO\n");
}
int main()
{
	int s,n,m;
	while((scanf("%d%d%d",&s,&n,&m),s||n||m))
	{
		a[0]=s,a[1]=n,a[2]=m;
		if(s%2)
		{
			printf("NO\n");
			continue;
		}
		bfs();
	}
}

posted @ 2015-11-01 21:12  上弦月307  阅读(134)  评论(0编辑  收藏  举报