hdoj--2138--How many prime numbers(暴力模拟)

How many prime numbers

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14686    Accepted Submission(s): 5093



Problem Description
  Give you a lot of positive integers, just to find out how many prime numbers there are.
 

Input
  There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
 

Output
  For each case, print the number of prime numbers you have found out.
 

Sample Input
3 2 3 4
 

Sample Output
2
 

Author
wangye
 

Source
HDU 2007-11 Programming Contest_WarmUp


#include<cstdio>
#include<cmath>
#include<string.h>
#include<algorithm>
using namespace std;
long long s,ans;
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		ans=0;
		int flog=1,i;
		for(int j=0;j<n;j++)
		{
			scanf("%lld",&s);
			for(i=2,flog=1;flog&&i<=sqrt(s);i++)
			if(s%i==0)
			flog=0;
			if(flog)
			ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}


 
posted @ 2015-12-20 17:56  上弦月307  阅读(228)  评论(0编辑  收藏  举报