青松

博客园 首页 新随笔 联系 订阅 管理
  154 Posts :: 3 Stories :: 39 Comments :: 0 Trackbacks

 

安装之前  

1、xcode安装

  # For Mac 
  # 先安装 [Xcode](http://developer.apple.com/xcode/) 开发工具,它将帮你安装好 Unix 环境需要的开发包

2、安装rvm

RVM 是干什么的这里就不解释了,后面你将会慢慢搞明白。

    $ curl -L https://get.rvm.io | bash -s stable

期间可能会问你sudo管理员密码,以及自动通过homebrew安装依赖包,等待一段时间后就可以成功安装好 RVM。

然后,载入 RVM 环境(新开 Termal 就不用这么做了,会自动重新载入的)

    $ source ~/.rvm/scripts/rvm

检查一下是否安装正确

    $ rvm -v
    rvm 1.22.17 (stable) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]

3、安装ruby

列出已知的ruby版本

   $ rvm list known

 

可以选择现有的rvm版本来进行安装(下面以rvm 2.0.0版本的安装为例)

 

    $ rvm install 2.0.0

同样继续等待漫长的下载,编译过程,完成以后,Ruby, Ruby Gems 就安装好了。

另附:

查询已经安装的ruby

  $ rvm list

卸载一个已安装版本 

      $ rvm remove 1.9.2

 

4、设置ruby版本

RVM 装好以后,需要执行下面的命令将指定版本的 Ruby 设置为系统默认版本

    $ rvm 2.0.0 --default

同样,也可以用其他版本号,前提是你有用 rvm install 安装过那个版本

这个时候你可以测试是否正确

    $ ruby -v
    ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-darwin13.0.0]

    $ gem -v
    2.1.6

这有可能是因为Ruby的默认源使用的是cocoapods.org,国内访问这个网址有时候会有问题,网上的一种解决方案是将远替换成
ruby-china的,替换方式如下:
  
$ gem source -r https://rubygems.org/     
$ gem source -a https://
gems.ruby-china.org/

 要想验证是否替换成功了,可以执行:

    $ gem sources -l  

正常的输出结果:

*** CURRENT SOURCES ***

 

https://gems.ruby-china.org/

            

到这里就已经把Ruby环境成功的安装到了Mac OS X上,接下来就可以进行相应的开发使用了。

 4、安装cocoapods

$ sudo gem install cocoapods

5、使用cocoapods

 http://www.code4app.com/article/cocoapods-install-usage

 

6、git clone太慢,参考

http://blog.csdn.net/menghuanbeike/article/details/74001756

posted on 2018-01-17 09:03  轻轻松松  阅读(78)  评论(0编辑  收藏