ZOJ1002 —— 深度优先搜索

ZOJ1002 —— Fire net

Time Limit: 2000 ms

Memory Limit: 65536 KB

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

ZOJ1002P1

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:

5
1
5
2
4

题目中译:

有n×n个格子,每个格子是堡垒或城墙或空地。

你原来知道哪里有城墙或空地。

堡垒会向东西南北四方向发射炮弹,城墙能阻挡炮弹。

问最多能放几个堡垒。

 

题目思维:

1.我们遍历每个格子,能放就放,并且将放完后与它有冲突的格子进行标记,最后输出。

可惜如果这样做不到最大优化。

2.我们仍然深度优先搜索每个格子,这次如果没有打过标记,则将格子标记0或1,如果标记过则只标记0,继续向下遍历,最后填满后更新最大值。

注意没打过表记的格子,打完标记要还原。

 

Code:

// by kyrence
#include <bits/stdc++.h>
using namespace std;

int n, ans;
bool can[10][10];
char c; 

bool valid(int x, int y) {
    return x > 0 && y > 0 && x <= n && y <= n;
}

void FW(int x, int y, int dx, int dy) {
    do {
        can[x][y] = 0;
        x += dx;
        y += dy;
    } while (valid(x, y) && can[x][y]);
}

void dfs(int dep, int tot) {
    if (dep > n * n) {
        ans = max(tot, ans);
        return;
    }
    dfs(dep + 1, tot);
    int x = (dep + n - 1) / n;
    int y = dep % n;
    if (!y) y = n;
    if (!can[x][y]) return;
    bool cam[5][5];
    for (int i = 1; i <= n; i++)
        for (int j = 1; j <= n; j++)
            cam[i][j] = can[i][j];
    FW(x, y, 1, 0); 
    FW(x, y, -1, 0); 
    FW(x, y, 0, 1); 
    FW(x, y, 0, -1);
    dfs(dep + 1, tot + 1);
    for (int i = 1; i <= n; i++)
        for (int j = 1; j <= n; j++)
            can[i][j] = cam[i][j];
}

int main() {
    while (scanf("%d", &n) == 1 && n) {
        ans = -1;
        for (int i = 1; i <= n; i++)
            for (int j = 1; j <= n; j++) {
                cin >> c;
                can[i][j] = (c == '.');
            }
        dfs(1, 0);
        printf("%d\n", ans);
    }
    return 0;
}
std

 

posted @ 2020-01-27 12:39  kyrence  阅读(228)  评论(0编辑  收藏  举报