VS2022 解决方案打不开 .NET Framework 4.0 、 4.5 等老项目

vs2022开发工具最低支持net4.8,以下的如net3.5、4.0、4.5项目,加载不上怎么处理。

一、下载.NET Framework框架 .NET Framework 4.5.2 .NET Framework 4.5.1 .NET Framework 4.5 .NET Framework 4.0,把框架放到vs安装目录下的对应包中。

microsoft.netframework.referenceassemblies.net40.1.0.2.nupkg

30.7M

microsoft.netframework.referenceassemblies.net45.1.0.2.nupkg

19.8M

microsoft.netframework.referenceassemblies.net451.1.0.2.nupkg

19.9M

microsoft.netframework.referenceassemblies.net452.1.0.2.nupkg

19.8M

二、解压缩 下载下来的包时.nupkg格式的,这里将其扩展名改为.zip,然后用解压缩软件解压。

三、copy复制v4.0、v4.5等到安装目录下

安装目标框架 将解压目录下的\build.NETFramework文件夹内的

v4.0或v4.5文件夹复制并覆盖到

C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework 目录下

四、记得重启一下VS2022 再重新打开VS2022并打开刚刚的项目

posted @ 2024-04-10 16:02  郑州-在路上  阅读(66)  评论(0编辑  收藏  举报