HDU 1029 Ignatius and the Princess IV (DP,水题)

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 34042 Accepted Submission(s): 14804

题目链接

Problem Description
“OK, you are not too bad, em… But you can never pass the next test.” feng5166 says.

“I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers.” feng5166 says.

“But what is the characteristic of the special integer?” Ignatius asks.

“The integer will appear at least (N+1)/2 times. If you can’t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha…..” feng5166 says.

Can you find the special integer for Ignatius?

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

Output
For each test case, you have to output only one line which contains the special number you have found.

Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

Sample Output
3
5
1

Author
Ignatius.L

简单题,主要要理解题意 (N+1)/2 这个条件很关键。

#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    int a,b,num,t;
    while(scanf("%d",&t)!=EOF)
    {
        scanf("%d",&a);
        num=1;
        for(int i=1;i<t;i++)
        {
            scanf("%d",&b);
            if(a==b)
                num++;
            else if(--num==0)
                a=b,num++;
        }
        printf("%d\n",a);
    }
    return 0;
}
posted @ 2017-08-14 10:46  南风古  阅读(89)  评论(0编辑  收藏  举报