B - Ancient Cipher POJ - 2159 解题报告

内容:

    Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping. The most popular ciphers in those times were so called substitution cipher and permutation cipher.
    Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all letters must be different. For some letters substitute letter may coincide with the original letter. For example, applying substitution cipher that changes all letters from 'A' to 'Y' to the next ones in the alphabet, and changes 'Z' to 'A', to the message "VICTORIOUS" one gets the message "WJDUPSJPVT".
    Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation <2, 1, 5, 4, 3, 7, 6, 10, 9, 8> to the message "VICTORIOUS" one gets the message "IVOTCIRSUO".
    It was quickly noticed that being applied separately, both substitution cipher and permutation cipher were rather weak. But when being combined, they were strong enough for those times. Thus, the most important messages were first encrypted using substitution cipher, and then the result was encrypted using permutation cipher. Encrypting the message "VICTORIOUS" with the combination of the ciphers described above one gets the message "JWPUDJSTVP".
    Archeologists have recently found the message engraved on a stone plate. At the first glance it seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that was encrypted, and now they want to check their conjecture. They need a computer program to do it, so you have to write one.
Input
    Input contains two lines. The first line contains the message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so the encrypted message contains only capital letters of the English alphabet. The second line contains the original message that is conjectured to be encrypted in the message on the first line. It also contains only capital letters of the English alphabet.
    The lengths of both lines of the input are equal and do not exceed 100.
Output
    Output "YES" if the message on the first line of the input file could be the result of encrypting the message on the second line, or "NO" in the other case.
Sample Input

    JWPUDJSTVP
    VICTORIOUS

Sample Output

    YES
View Code

刚开始理解错了题意,好不容易弄明白。。。

题目大意:

给出了两行有大写字母组成的字符串,问能否将第一行经过替换和置换得到第二行。

替换指将该字符串每个字母加上一个相同的数后得到

置换指将字符串顺序调换

所以只要按此逆序来查看就可以,可以将字母按大小排序,再看出现频率是否相同也行。

思路:实际只要统计两个字符串中各字符出现的次数是否一样即可,即分别统计两个字符串中各字符的出现次数,再由小到大排序,比较即可,若全相同,则输出“YES”,若不同,则直接输出“NO”

代码:

#include<iostream>
#include<string>
#include<cstring>
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
    string s,b;
    int a[50],w[50];
    memset(a,0,sizeof(a));
    memset(w,0,sizeof(w));
    cin>>s;
    getchar();
    cin>>b;
    int m;
    m=s.size();
    for(int i=0;i<m;i++)
    {
        a[s[i]-'A']++;
        w[b[i]-'A']++;
    }
    sort(a,a+26);
    sort(w,w+26);
    int p=0;
    for(int i=0;i<26;i++)
    {
        if(a[i]!=w[i])
        {
            p=1;
            break;
        }
      cout<<a[i]<<" "<<w[i]<<endl;//该行要去掉,只是为了清楚比较
    }
    if(p==1)cout<<"NO"<<endl;
    else
        cout<<"YES"<<endl;
}

结果显示:

 

posted @ 2021-06-04 21:34  西瓜0  阅读(48)  评论(0编辑  收藏  举报