mthoutai

  博客园  :: 首页  :: 新随笔  :: 联系 :: 订阅 订阅  :: 管理

Problem Description

Welcome to XTCPC! XTCPC start today, you are going to choose a slogan to celebrate it, many people give you some candidate string about the slogan, but the slogan itself must have something relavant to XTCPC, a string is considered relevant to XTCPC if it become XTCPC after deleting some characters in it. For example, XTCPC, XTCCPCC, OIUXKKJATSADCASPHHC is relevant, XX,FF,GG,CPCXT,XTCP is not. Now you have to write a program to judge whether a string is relevant to XTCPC.

Input

First line an integer t(t≤100), the number of testcases. For each case, there is a string(length≤100, all are uppercase characters).

Output

For each case, output case number first, then "Yes" if the string is relevant, "No" if the string is not relevant. Quote for clarify.

Sample Input

3
XTCPC
CCC
XXXXTTTTCCCCPPPCCC


Sample Output

Case 1: Yes
Case 2: No
Case 3: Yes

签到题,一道字符串的水题。这样的题目还是要争取1A,不要耗费太多的时间;
#include <cstdio>
#include <cstring>
char s[101];
char c[6]={'X','T','C','P','C'};
int main()
{
    int t,i,j,id;
    scanf("%d",&t);
    for(i=1;i<=t;i++)
    {
        id=0;
        scanf("%s",s);
        for(j=0;j<strlen(s);j++)
        {
            if(s[j]==c[id])
                id++;
        }
        if(id==5)
            printf("Case %d: Yes\n",i);
        else
            printf("Case %d: No\n",i);
    }
}


posted on 2017-05-31 18:12  mthoutai  阅读(182)  评论(0编辑  收藏  举报