1081 Rational Sum (20 分)(分数的四则运算)

Given N rational numbers in the form “numerator/denominator”, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers “a1/b1 a2/b2 …” where all the numerators and denominators are in the range of “long int”. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form “integer numerator/denominator” where “integer” is the integer part of the sum, “numerator” < “denominator”, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

生词

英文 解释
numerator 分子
denominator 分母
fractional 分数的

分析:

先根据分数加法的公式累加,后分离出整数部分和分数部分
分子和分母都在长整型内,所以不能用int存储,否则有一个测试点不通过
一开始一直是浮点错误,按理来说应该是出现了/0或者%0的情况,找了半天也不知道错在哪里
后来注意到应该在累加的时候考虑是否会超出long long的范围,所以在累加每一步之前进行分子分母的约分处理,然后就AC了~
以及:abs()在stdlib.h头文件里面

应该还要考虑整数和小数部分都为0时候输出0的情况,但是测试用例中不涉及,所以如果没有最后两句也是可以AC的(PS:据说更新后的系统已经需要考虑全零的情况了~)

原文链接:https://blog.csdn.net/liuchuo/article/details/52139107

题解

#include <bits/stdc++.h>

using namespace std;
struct frac{
 long int num,den;
}fracs[101];

long int gcd(long int a,long int b){
    if(b==0) return a;
    else return gcd(b,a%b);
}
long int gcd1(long int a,long int b){
    long int re=gcd(a,b);
    return a/re*b;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n;
    string s,sub1,sub2;
    cin>>n;
    for(int i=0;i<n;i++){
        int cnt=0;
        cin>>s;
        if(s[0]=='-') cnt=1;
        for(int j=0;j<s.length();j++)
        {
            if(s[j]=='/'){
                sub1=s.substr(cnt,j-cnt);
                sub2=s.substr(j+1,s.length()-j-1);
                break;
            }
        }
        if(s[0]=='-') fracs[i].num=-stol(sub1);
        else fracs[i].num=stol(sub1);
        fracs[i].den=stol(sub2);
    }
    long int re=gcd1(fracs[0].den,fracs[1].den);
    for(int i=2;i<n;i++){
        re=gcd1(re,fracs[i].den);
        //cout<<fracs[i].num<<" "<<fracs[i].den<<endl;
    }
    long int sum=0;
    for(int i=0;i<n;i++){
        sum+=fracs[i].num*=re/fracs[i].den;
    }
    if(sum==0||re==0){
        cout<<0;
        return 0;
    }
    if(sum<=re){
        cout<<sum/gcd(sum,re)<<"/"<<re/gcd(sum,re);
    } else{
        if(sum%re==0) cout<<sum/re;
        else{
            long int inte=sum/re;
            cout<<inte<<" ";
            sum-=re*inte;
            cout<<sum/gcd(sum,re)<<"/"<<re/gcd(sum,re);
        }
    }
    return 0;
}

柳神答案

我傻了,我为啥要用字符串,用scanf自定义输入啊,,,

#include <iostream>
#include <cstdlib>
using namespace std;
long long gcd(long long a, long long b) {return b == 0 ? abs(a) : gcd(b, a % b);}
int main() {
    long long n, a, b, suma = 0, sumb = 1, gcdvalue;
    scanf("%lld", &n);
    for(int i = 0; i < n; i++) {
        scanf("%lld/%lld", &a, &b);
        gcdvalue = gcd(a, b);
        a = a / gcdvalue;
        b = b / gcdvalue;
        suma = a * sumb + suma * b;
        sumb = b * sumb;
        gcdvalue = gcd(suma, sumb);
        sumb = sumb / gcdvalue;
        suma = suma / gcdvalue;
    }
    long long integer = suma / sumb;
    suma = suma - (sumb * integer);
    if(integer != 0) {
        printf("%lld", integer);
        if(suma != 0) printf(" ");
    }
    if(suma != 0)
        printf("%lld/%lld", suma, sumb);
    if(integer == 0 && suma == 0)
        printf("0");
    return 0;
}
posted @ 2022-01-02 10:49  勇往直前的力量  阅读(36)  评论(0编辑  收藏  举报