POJ 2356 Find a multiple

Find a multiple
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4934   Accepted: 2139   Special Judge

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3
题目大意:给出N 个数,在其中找出m个数,使得m个数的和是N的倍数,输出m以及任意顺序这m个数,只要输出一种情况。
解题方法:这道题测试数据很水,直接保利搜索就可以解决。
#include <stdio.h>
#include <iostream>
using namespace std;

int n;
int num[10005];
int result[10005];
int visted[10005];

bool DFS(int nCount, int sum)
{
    if (nCount <= n)
    {
        if (sum % n == 0 && sum != 0)
        {
            printf("%d\n", nCount);
            for (int i = 0; i < nCount; i++)
            {
                printf("%d\n", result[i]);
            }
            return true;
        }
        for (int i = 0; i < n; i++)
        {
            if (!visted[i])
            {
                result[nCount] = num[i];
                visted[i] = 1;
                if (DFS(nCount + 1, sum + num[i]))
                {
                    return true;
                }
                visted[i] = 0;
            }
        }
    }
    return false;
}

int main()
{
    scanf("%d", &n);
    for (int i = 0; i < n; i++)
    {
        scanf("%d", &num[i]);
    }
    if (!DFS(0, 0))
    {
        printf("0\n");
    }
    return 0;
}

 

posted on 2013-08-03 10:35  lzm风雨无阻  阅读(184)  评论(0编辑  收藏  举报

导航