数据结构实验之链表七:单链表中重复元素的删除-sdut

数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

Input

第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。

Output

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

Example Input

10
21 30 14 55 32 63 11 30 55 30

Example Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

实验代码

#include <stdio.h>
#include <stdlib.h>

typedef struct mode_t
{
    int data;
    struct mode_t *next;
} play;

int main()
{
    play *head, *tail, *p, *q, *c;
    int n, i;
    scanf("%d",&n);
    head=(play *)malloc(sizeof(play));
    tail=(play *)malloc(sizeof(play));
    head->next=tail;
    tail->next=NULL;
    for(i=0; i<n; i++)
    {
        p=(play *)malloc(sizeof(play));
        scanf("%d",&p->data);
        head->next=p;
        p->next=tail;
        tail=p;
    }
    printf("%d\n",n);
    tail=head->next;
    while(tail->next->next!=NULL)
    {
        printf("%d ", tail->data);
        tail=tail->next;
    }
    printf("%d\n", tail->data);//输出前两行计算结果
    p=head->next;
    tail=head->next;
    while(tail->next!=NULL)
    {
        p=tail;
        q=p->next;
        while(q->next!=NULL)
        {
            if(q->data==tail->data)
            {
                c=q;
                q=q->next;
                p->next=p->next->next;
                n--;
                free(c);
            }
            else
            {
                p=p->next;
                q=q->next;
            }
        }
        tail=tail->next;
    }
    printf("%d\n",n);
    tail=head->next;
    while(tail->next->next!=NULL)
    {
        printf("%d ", tail->data);
        tail=tail->next;
    }
    printf("%d\n", tail->data);
    return 0;
}

 

posted on 2017-03-27 21:43  ouon.cc  阅读(319)  评论(0编辑  收藏  举报