最大乘积(Maximum Product,UVA 11059)

 

Problem D - Maximum Product

Time Limit: 1 second

 

Given a sequence of integers S = {S1, S2, ..., Sn}, you should determine what is the value of the maximum positive product involving consecutive terms ofS. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each elementSi is an integer such that-10 ≤ Si ≤ 10. Next line will haveN integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: Case #M: The maximum product is P., whereM is the number of the test case, starting from1, andP is the value of the maximum product. After each test case you must print a blank line.

Sample Input

3
2 4 -3

5
2 5 -1 2 -1

Sample Output

Case #1: The maximum product is 8.

Case #2: The maximum product is 20.



 

#include <stdio.h>
#include <set>

using namespace std;

int main(){
	int n;
	int * val = NULL;
	set<long long> s;
	while((scanf("%d",&n) == 1) && n != 0){
		val =  new int[n];
		int i = 0;
		for (;i  < n; i++) {
			scanf("%d",&val[i]);
		}
		s.clear();
		int j ;
		for(i = 0;i < n -1;i++){	//枚举起点

			for (j = i; j < n; ++j) {//枚举终点
				int k;long long ji = 1;
				for(k = i; k <= j;k++){
					ji *= val[k];
				}
				s.insert(ji);
			}

		}

		long long max = *(s.rbegin());
		if(max > 0){
			printf("%ld\n",max);
		}
		else{
			printf("0\n");
		}
                delete val;
        }


	return 0;

}


 



 

posted @ 2014-08-27 15:13  lvyahui  阅读(612)  评论(0编辑  收藏  举报