gradle常见问题汇总

Q1:

Gradle version 1.10 is required. Current version is 2.0

A1:

Message: "Gradle version 1.10 is required. Current version is 2.0"

Occurs when: Attempting to build an Android project that requires 1.10 version of Gradle while using 2.0 version of it as native.

Solution: Using Gradle Wrapper

Steps:

  1. Make sure the distributionUrl is specified as gradle-1.10-all.zip at the Gradle-wrapper properties file within the Android project. The file path would be like this:

    MyAndroidProject/gradle/wrapper/gradle-wrapper.properties

  2. Run Gradle Wrapper command at the very top level of the project where the executable scripts (i.e. gradlew and gradlew.bat) are located.

    For Unix-like OS:

    ./gradlew wrapper

    For Windows OS:

    gradlew.bat wrapper

  3. Run build command with Gradle Wrapper.

    For Unix-like OS:

    ./gradlew build

    For Windows OS:

    gradlew.bat build

Q2:

Caused by: java.io.IOException: Cannot run program "ndk-build" (in directory "E:\AndroidEmulatorDetection-master\app"): CreateProcess error=2

A2:

Assuming you are running from a window OS...

Try changing from: D:\android-ndk-r7c\ndk-build to: D:\android-ndk-r7c\ndk-build.cmd

Q3:

 

A3:

local.properties中ndk.dir的路径不能包含空格

 

附local.properties:

sdk.dir=D\:\\Program Files\\Android\\sdk
ndk.dir=D\:\\android-ndk-r10e

 

posted @ 2015-07-23 11:56  luzhiyuan  阅读(...)  评论(... 编辑 收藏