UVA Summation of Four Primes

Summation of Four Primes

Input: standard input

Output: standard output

Time Limit: 4 seconds

 

Euler proved in one of his classic theorems that prime numbers are infinite in number. But can every number be expressed as a summation of four positive primes? I don’t know the answer. May be you can help!!! I want your solution to be very efficient as I have a 386 machine at home. But the time limit specified above is for a Pentium III 800 machine. The definition of prime number for this problem is “A prime number is a positive number which has exactly two distinct integer factors”. As for example 37 is prime as it has exactly two distinct integer factors 37 and 1.

 

Input

The input contains one integer number N (N<=10000000) in every line. This is the number you will have to express as a summation of four primes. Input is terminated by end of file.

 

Output

For each line of input there is one line of output, which contains four prime numbers according to the given condition. If the number cannot be expressed as a summation of four prime numbers print the line “Impossible.” in a single line. There can be multiple solutions. Any good solution will be accepted.

 

Sample Input:

24
36
46

 

Sample Output:

3 11 3 7
3 7 13 13
11 11 17 7

/*
首先这里涉及哥德巴赫猜想
即一个偶数可以拆成2个素数的和
对于此题 此题是special judge
所以任何可行解都可以 如果输入的是一个偶数 那么就拿出2个2 剩下的 n-4还是偶数 拆分这个偶数就行了
对于奇数就拿出一个2 一个 3剩下的n-5还是偶数 拆分这个偶数就行了
ps:n<8是一定不可以拆的
*/
#include<stdio.h>
#define N 10000005
int vis[N];
int prime[700000];
int main()
{
     int i,j,n,k;
     k=0;
     for(i=2;i<N;i++)//强大的素数筛选算法60多万的素数表
     {
          if(!vis[i])
          {
               prime[k++]=i;
               for(j=i+i;j<N;j+=i)  vis[j]=1;
          }
     }
     while(~scanf("%d",&n))
     {
          if(n<8) {printf("Impossible.\n");continue;}
          if(n%2) {printf("2 3 ");n-=5;}
          else {printf("2 2 "); n-=4;}
          for(i=0;i<k;i++)
               if(!vis[n-prime[i]])//n是偶数 prime[i]是素数n-prime[i]也是素数
          {
               printf("%d %d\n",prime[i],n-prime[i]);
               break;
          }
     }

     return 0;
}

 


posted @ 2013-09-04 22:00  SprayT  阅读(243)  评论(0编辑  收藏  举报