poj 2345 Aggressive cows

Aggressive cows
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4737   Accepted: 2316

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int pos[200000],n,m;
using namespace std;
int judge(int w)
{
     int i,cnt=pos[0],sum=1;
     for(i=1;i<n;i++)//贪心
     {
          if(pos[i]-cnt>=w)
          {
                sum++;
            if(sum>=m)
            return 1;
            cnt=pos[i];
          }

     }
     return 0;
}
int main()
{
     int i;
     while(scanf("%d %d",&n,&m)!=EOF)
     {
          memset(pos,0,sizeof(pos));

          for(i=0;i<n;i++)
          scanf("%d",&pos[i]);
          sort(pos,pos+n);
          int l,r,mid;
          l=0;
          r=pos[n-1]-pos[0];
          while(l<=r)//二分答案
          {
               mid=(l+r)/2;
               if(judge(mid))
               l=mid+1;
               else
               r=mid-1;

          }
          printf("%d\n",l-1);
     }

     return 0;
}

 

posted @ 2013-07-31 21:56  SprayT  阅读(285)  评论(0编辑  收藏  举报